Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey all, first I'm new here and my 1995 Impala SS is my first ever "project car", so please be nice because I'm learning everything for the first time. My intention is do everything on my own versus paying someone to do the work on as much as possible.
I've seen several issues with the gauge cluster not working properly. I think I've tried the "common" "it could be" scenarios.
Digital speedometer and mileage- does not work- at all.
Gas and Temp gauges- work but not properly. Example- the Temp gauge when the car is off and has not been running shows right in the middle and immediately upon starting the car shows its hot. The gas gauge- by the time it shows 1/4 tank- means it's already empty.
I have removed the cluster and carefully cleaned the connection points with a Q-tip and alcohol. As well as checked all fuses.

Someone recommended getting another cluster from a junk yard (that works) and hooking it up to see it is actually my cluster with the problem or possibly the wiring to the cluster- but while that may be a possibility doesn't make sense why the gauges would be "off" I would think they just wouldn't work at all if that were the case. (Again I'm new to this so please tell me otherwise if I'm wrong).

So what should I try next. I've looked into shipping it off for repair, but if this is something simple I would be able to attempt first I would definitely prefer that route before handing my car (or a piece of it over). This isn't me trying to be cheap and not wanting to pay to fix it, this is simply a personal preference of wanting to be able to say I actually put the work into my new baby versus having someone else do the labor.

Thanks ahead of time for your help!!
 

·
Super Moderator
Joined
·
12,438 Posts
The cluster gauges use what are called "stepper motors". As these age, they no longer work correctly and show incorrect values on the gauges. To me, it sounds like the stepper motors for a few of the gauges are no longer calibrated properly. I'd probably just just a new (used) cluster off of Ebay or a junkyard. I'm not sure about a 95 Impala, but newer Impalas store the mileage in the cluster itself, so if you replace the cluster, the mileage shown will probably not be accurate (it will be the mileage from the car that the cluster came out of) - just something to be aware of.

Hope that helps.

Sent from my Hi10 pro using Tapatalk
 
1 - 3 of 3 Posts
Top