Impala Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Sorry for the last post, New discovery dont post when hammered:beer:

I got a 05 impala just got it im not sure but i think the gas gauge is bad i put 30 bucks in it the other day ( Gas light was on) and it was 7.8 Gallons and it put me at About Three Quarters of a tank is that wrong doesnt seem right with a 17 gallon tank. Also the Gas needle drains pretty fast.

Thanks
 

·
Registered
Joined
·
33 Posts
When you turn the ignition on will it jump to under "E" then to the level or when off is it showing a level? Could be a bad step motor. My cluster is starting to act up. Time to send it to BBE.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
No it never goes under E when i turn it on it shoots up to how ever much gas is it in, I think its fine tho because that 7.8 gallons got me 190 miles which is 23mpg, thats combined between Highway and City. The needle does go down fast tho if i go about 5 or 6 miles the it shows on it has less gass already, Know what i mean? i just put 4.4 gallons when it was on the E and it put it at almost Half and now its under a Quarter tank in just 30 miles.. the Gas light does come on one line before E, I just wanna make sure its not bad because there Clusters are Expensive..
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Well, fill it up when you can. See if it goes past full. If the cluster goes bad you can have it rebuilt. http://http://www.bbengineer.com/cars/impala/store.htm I have a base 3.4lt and get 26-27 in combination driving.
Okay i will try that thanks buddy im going to monday when i get paid. It doesnt need a tune up and everything i checked all that it seems like it not getting as good MPG as it should.. I got the 3.4L as well
 
1 - 9 of 9 Posts
Top