Impala Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hey guys, im usually just lurking the forums gathering info but im a lil stumped on my intermittent acceleration issues. for the most part my acceleration is on point and strong, its the times it bogs down that throws me in a loop. im assuming a fuel or sensor issue. the car is well maintained weather it be spark plugs/wires/seafoam/oil change/fuel filter/ cleaning throttle body/ cleaning maf/new 02 sensor/clean iac.

i even changed the fuel pump because i thought that was causing my fuel gauge to fluctuate.
took this picture a couple weeks after new pump was put on, hasnt did it since tho



Here i Made a video testing the fuel pressure, guess thats a start. thanks.
2005 impala 3.4

 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
sorry bout thread title, it was more of a "is my fuel pressure normal" type of thing. everything else is just extra info.

KOEO 52-59psi
my KOEO shoots too 55psi, then drops to about 49-50psi, would that still be considered normal?

Idle fuel pressure looks about 46-47psi

Rev'n the engine it rises to about 50psi.

FPR w/o vacuum line - 59 psi
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Specs are the same for engine on or off, so idle should still be 52-59
 

·
Super Moderator
Joined
·
7,057 Posts
One thing you have not mentioned is whether you have changed the fuel pressure regulator. If not I would consider changing it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Specs are the same for engine on or off, so idle should still be 52-59
seems like im not achieving that either way...

One thing you have not mentioned is whether you have changed the fuel pressure regulator. If not I would consider changing it.
concerning the fpr , i replaced it maybe 2 years ago because it was actually leaking.

with the current one i've pulled off the vacuum too check and see if it was wet or smells like fuel. definitely not wet, but there is a "hint" (very very small) of a fuel smell or exhaust smell. are the lines suppose too be bone dry including smell?
 

·
Super Moderator
Joined
·
7,057 Posts
Might want to replace it again since it is 2 years old. It may well be the problem.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Yea im going too look into that, ill most likely grab me a scanner w/ live data, im sure that'll tell me alot , instead of diving straight into a replacement Fpr
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
i have some new info. ive already changed the fpr, i never re checked the pressure after changing until recently because of new issues. Key on w/ engine off PSI shoots up then immediately goes to 0 psi. Key on w/ engine on im steady at 50psi, soon as the car cuts off the psi shoots to 0 psi ? Fuel Filter? Fuel Pump (again)? or something else. thanks
 
1 - 10 of 10 Posts
Top