Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
front was clunking when i hit bumps. since car was at 100k, i replaced the struts/sway links/tire rods. was fine for a bit, then started clunking again

after dicking with about everything i could, including taking it to the dealer....they "couldnt find anything"

I found what it was

the BRAND @#$#ing NEW sway bar links were shit. I got them thru orilley---they were solid metal instead of the plastic OEM ones.

short story long---i got the metal ones because they were greaseable. they seemed fine but i had to grease them like every 1k to keep them "tight/not clunking" i said f-it and let it buck, and after 2-3k they were just unbearable...just noisy as duck.

ended up getting the oem-style plastic ones back in yesterday-- zero clunking..now fixed.

prob will trash the other set from oriley-- doubt they would take them back...as they look fine...

sigh
 

·
Registered
Joined
·
1,793 Posts
front was clunking when i hit bumps. since car was at 100k, i replaced the struts/sway links/tire rods. was fine for a bit, then started clunking again

after dicking with about everything i could, including taking it to the dealer....they "couldnt find anything"

I found what it was

the BRAND @#$#ing NEW sway bar links were shit. I got them thru orilley---they were solid metal instead of the plastic OEM ones.

short story long---i got the metal ones because they were greaseable. they seemed fine but i had to grease them like every 1k to keep them "tight/not clunking" i said f-it and let it buck, and after 2-3k they were just unbearable...just noisy as duck.

ended up getting the oem-style plastic ones back in yesterday-- zero clunking..now fixed.

prob will trash the other set from oriley-- doubt they would take them back...as they look fine...

sigh


Can’t go wrong with OEM parts.

The links are not plastic, but rather a nylon composite.
 
1 - 3 of 3 Posts
Top