Impala Forums banner

1 - 20 of 35 Posts

·
Cucky
Joined
·
662 Posts
Discussion Starter #1
I have a 3.9l with flowmasters and the res removed. Everytime I rev it or get over 4,000rpms and let the Roms come back down it makes a rattle sound. Can someone help me in how to get rid of this? It did this with the res still on too so its not the fact that I removed it. Ill post a video soon of it. I need help and this is driving me crazy.
 

·
Banned
Joined
·
2,492 Posts
umm....push it off a cliff and always drive the vette??!! hah! what's it like to park the vette and step into the Impy? Is it as big a let down as it sounds?
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Could be a loose baffle or heat shield. Or maybe it's your exhaust system growing...
 

·
Banned
Joined
·
2,492 Posts

·
8th Gen Antagonist
Joined
·
13,660 Posts
Not myself, or likely TSS either, no.
 

·
Banned
Joined
·
2,492 Posts
hahaha, can you post a link to the original incident? I'd like to get to know how that went down....I know the backstory, but still..
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Every time someone complains about a vibration, Tricia chimes in with the standard list of possible causes, exhaust system growth being on the list. Road selection was another funny one.
 

·
Banned
Joined
·
2,492 Posts
try to remember that when things get hot, they expand, and therefore there is growth involved, and when it cools and shrinks, it could develop rattles...if it was poorly assembled....which isn't outside the realm of possibilities.
 

·
SStuntin on em
Joined
·
4,851 Posts
eh, she said it can grow like 6 inches or something. the way it was worded it just sounded rediculous
 

·
Banned
Joined
·
2,492 Posts
:lol: I got nothing....I can't defend that...
 

·
Banned
Joined
·
2,492 Posts
or excite it in anyway...
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Watch out for the discharge!

Now that we've completely derailed this thread... Any luck finding the source?
 

·
Banned
Joined
·
2,492 Posts
I take responsibility for the derailment, I started off with the wisecracks and it snowballed from there, my bad.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Like I said before, probably a loose baffle or heat shield. Heat shield you should be able to track down by inspecting the exhaust under the car. Baffle, I would try thumping and shaking the mufflers and see if you hear anything. A friend of mine had a baffle come out of his flowmaster, I remember him showing me this piece of metal and saying "this came out of my tailpipe, what is it?" really there was only one thing it could be.
 
1 - 20 of 35 Posts
Top