Impala Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
588 Posts
Discussion Starter · #1 ·
2000 Impala LS 176k

Well I am not sure yet what the problem is. I know that it has to do with EVAP, Last time gas was added my son put the cap on so I took cap off and re installed it. However I wasn't able to reset the code because just last week I sent my scanner off to my Brother so he could use it LOL now I need it...

So I am just wondering if this may have something to do with the Vac line for the HVAC, IT had broke off and came to rest on my exhaust pipe and melted shut, However when I noticed I wasn't able to move from Defrost I went looking and found it there. So when I went to pick it up it broke off. I wonder if that open line would cause the P0440?

I am not sure if the Line for the HVAC would be off the EVAC area. Anything anyone with this code other then Gas cap and Purge Solenoid? Dislike issues related to fuel. I am more of a Electronics kind of person lol...

James
 

·
Registered
Joined
·
2,291 Posts
I know mine was caused by the purge solenoid....but then I got the ZZP PCM and don't have to worry about those codes anymore lol :)
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #3 ·
Thank you for the Reply. Don't mind me I am sorry at times I have to say I don't think about things to well... After thinking more about things it dawned on me that I have the 2000 Chevy Impala Service Manuals. So on Page 6-751 it starts off what I need to do for testing...

Another thing why I love the HUM product by my Cell Carrier. It isn't every moment of the day that I am looking at my cluster area where the MIL/CEL is placed. While I was on my way home today before I got out of the Wal-Mart parking lot my Email popped up while I was at the Light, Said Hum so I looked at the dash and sure enough CEL was on. Gave it to my son to check my Email, Hum sent an Email stating that I had the CODE and a rather long Description of what the code was... I didn't and most likely won't call but it even provides a 800 number to contact the Hum Mechanics Hotline if I want or needed more info about this problem...

So good news is that if it was only my Gas Cap (Won't hold my breath) looking at my Service Manual it says it will clear the code once the problem is solved after 3 run times that testing passed. Sure beats some of the others that I had read about where the run times was 100 lol

So here is what it says for anyone that has an 2000 impala that gets this code, "The Following conditions will sed DTC P0440;

A Missing, Not completely installed or malfunctioning fuel fill cap
A disconnected, damaged, pinched, or blocked EVAP purge line
A disconnected or damaged EVAP vent hose
A disconnected, damaged, pinched, or blocked fuel tank vapor line
A Malfunctioning EVAP canister purge valve
A malfunctioning EVAP vent valve
An open ignition feed circuit to the EVAP vent or purge valve --
--This should also set DTC P0443 or P0449 <Not my issue>
A damaged EVAP canister
A leaking fuel sender assembly O-Ring
A leaking fuel tank or fuel filler neck"

Anyway just thought I would post that. I will figure this out. My Gas cap a few month ago was making a funny noise so I might just replace that for good measure.

James
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #4 ·
Strange thing today. Went to Pick N Pull to pick a couple parts and not many gas caps. Found 2 that looked better then mine and also picked a Acdelco 214641 purge valve. I figure I will put different part in see if it goes away. Thought seeing I got another notice with same code. May need to do some testing to get the right part. Get in car and start it and light goes out lol. only thing I have done is put gas cap on not even the pulled one. Also bought a cheap scanner to use when I loan out my good one. Sadly have to wait 10 days for it. Not to cheap but does srs and abs so worth it to have back up.
Here is the Hum notice from yesterday



Sent from my VS880 using Tapatalk
 
1 - 4 of 4 Posts
Top