Impala Forums banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Recently my impala does not start. Tried fixing the distriburtor and its ok but still does not start. I brought a friend of my to see what was wrong with it. He said there wasnt a strong spark from the spark plugs. Do you think there is a problem with the spark plugs or something else thats all he said might be the problem. Also the fuel line is ok. Havent done nothing since that problem need some advice.
 
G

·
Discussion Starter · #2 ·
A car this old has mechanical "points" instead of electronic ignition. Points need to be replaced and adjusted every so often. Don't know how long you have driven this car, but I would find an old mechanic to check the "points"
 
G

·
Discussion Starter · #3 ·
Without knowing what recent maintenance has been done, I would recommend checking all the connections for corrosion and maybe replacing the coil. The plug wires may also be bad. Without being able to see it or knowing what has been done to it, all we can do is guess.
 

·
Registered
Joined
·
94 Posts
Running cars

Cars need four things to run. Air, fuel, spark, and compression. IF you have a decent air filter, so the car can "breathe" and no major vacuum leaks (it'd really take a duesy to make it not run at all) and spark (assuming your friend is right), That narrows it down to fuel as far as I can see. Assuming the compression is good, which it almost certainly is.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top