Impala Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hey guys i have a but of a problem. This morning i filled my car up with gas and hopped on the parkway. Once i got up to speed my engine start dropping revs and it felt like it was constantly misfiring. When i finally got to my destination i went to make a low speed left turn into a parking spot the steering got heavy and the car died on me. Any ideas what’s the problem?
 

·
Registered
Joined
·
2,675 Posts
Hey guys i have a but of a problem. This morning i filled my car up with gas and hopped on the parkway. Once i got up to speed my engine start dropping revs and it felt like it was constantly misfiring. When i finally got to my destination i went to make a low speed left turn into a parking spot the steering got heavy and the car died on me. Any ideas what’s the problem?
Were you able to restart it after it died? When you felt it misfiring, was the check-engine light flashing? My first thought was that you got some bad gas. Sorry, but I must ask, are you sure you didn't put diesel in it when you got gas?

Doug

.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Hey Doug, thank you for responding. After the first time it died i was able to restart it right after and park the car. An hour later i had it towed and was able to start the car again and move it behind the tow truck. about 30 mins later the tow truck driver was able to drive it into my driveway. after I got home from school, a few hours later, i was not able to start the car so my father and i brought the battery to an auto store and had it tested. the battery wasn't bad but the guy said it did need a charge. i did end up buying a new battery and i put that in my car and had the alternator tested and the guy said it was working fine. me and my father then proceeded to drive the car for about an hour after putting fuel injector cleaner in it and it continued to misfire and hold gears and drop revs. i'm positive i didn't put diesel in it and i am starting to worry that it might be a transmission problem. no check engine lights flashed and i scanned the car with an obd-2 scanner and read no codes. if you have any more help please let me know it will be greatly appreciated.

Steven Blumberg
 

·
Registered
Joined
·
2,675 Posts
Hey Doug, thank you for responding. After the first time it died i was able to restart it right after and park the car. An hour later i had it towed and was able to start the car again and move it behind the tow truck. about 30 mins later the tow truck driver was able to drive it into my driveway. after I got home from school, a few hours later, i was not able to start the car so my father and i brought the battery to an auto store and had it tested. the battery wasn't bad but the guy said it did need a charge. i did end up buying a new battery and i put that in my car and had the alternator tested and the guy said it was working fine. me and my father then proceeded to drive the car for about an hour after putting fuel injector cleaner in it and it continued to misfire and hold gears and drop revs. i'm positive i didn't put diesel in it and i am starting to worry that it might be a transmission problem. no check engine lights flashed and i scanned the car with an obd-2 scanner and read no codes. if you have any more help please let me know it will be greatly appreciated.
I'm wondering if you have a bad fuel pump. You can test that using a fuel pressure gauge which you can borrow at parts stores. Or it could also be a bad fuel pressure regulator. Those are the next two areas I'd pursue. It sounds like your engine is cutting out, but not really misfiring. So I'm thinking fuel.

Doug

.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
I'm wondering if you have a bad fuel pump. You can test that using a fuel pressure gauge which you can borrow at parts stores. Or it could also be a bad fuel pressure regulator. Those are the next two areas I'd pursue. It sounds like your engine is cutting out, but not really misfiring. So I'm thinking fuel.

Doug

.
yeah i googled the symptoms of bad gas and what was happening matched up with most of them so fuel is at the top of my list right now. i'm justing begging it isn't tranny related. thank you so much for your help Doug it's very appreciated.

Steven Blumberg
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
My new problem now is the speedometer needle keeps dropping when i reach 50 and the car starts to jerk foward and it sounds like it’s going to stall. Any ideas what that is?
 
1 - 8 of 8 Posts
Top