Impala Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello. I have an 07 impala LT engine 3.5 V6. So I did the coolant flush I followed a video. But I'm not sure if I used the right coolant.... I recently bought the car and when I saw the coolant container thing reservoir I think it's called it was literally empty I couldn't tell what color it was.... I didn't know i could check from radiator ( I know now after doing the flush) so the one I put in is AutoZone extended life antifreeze and coolant 50/50 dex- cool compatible do not add water. Can someone please let me know if it's the right one? It's orange color.
 

·
Registered
Joined
·
588 Posts
Yes DexCool is what you want to use. 50/50 is good for not having to make your own... IF your in really cold area you could get Concentrate and mix your own to help if 50/50 isn't good enough. But should be. If you mix your own in future also use Distilled Water for best results...

James

Welcome to the Forum hope your stay is a good one
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yes DexCool is what you want to use. 50/50 is good for not having to make your own... IF your in really cold area you could get Concentrate and mix your own to help if 50/50 isn't good enough. But should be. If you mix your own in future also use Distilled Water for best results...

James

Welcome to the Forum hope your stay is a good one
You're the man. Thank you so much. And yep I used the distilled water! Appreciate it man.
 
1 - 3 of 3 Posts
Top