Impala Forums banner

1 - 7 of 7 Posts
G

·
Discussion Starter #1
battery goes dead on 2007 corvette ! after fully charged ,it is dead next day ! any one having similar problems . Appreciate your input!
 
G

·
Discussion Starter #2
you have a drain somewhere, or a direct short, could be the alternator or the positive battery wire is hitting something and it cut the coating( insulation) on the wire, are yo uleaving a dome light on ? or the radio? take it to a auto electric shop ( or back to the dealer)
 
G

·
Discussion Starter #3
Yeah, it could be a faulty alternator, loosen the positive cable, start it up and pull the positve cable off of the battery post. I f it dies then you have a bad alternator, if it runs then you have a bad battery. Brand new things can go bad , especially electrical components, so hope this helps a little.
 
G

·
Discussion Starter #4
Something Is Not Shutting Off . The Alternator Wont Draw It Just Wont Recharge , It Could Be Anywhere , Electric Shorts Are A Nightmare And Can Cost A Fortune To Find If You Take It To A Shop
 
G

·
Discussion Starter #6
If it's a 6-speed, your problem is there is a drain when the vehicle is parked and it's not in reverse. For some reason, some of the computer functions still monitor the car even when it's shut off. Charge it, drive it, and leave it in reverse when it's parked and you shouldn't have any more problems. The same drain occurs in all of the C-6 Corvettes with a 6-speed transmission, including the Z-06's.

If it's an automatic, take it in to service, and don't worry because that's a warranty issue anyway.
 
G

·
Discussion Starter #7
des battry hold charge may have dead cell load test battery or altenator output is badstartewr might be bad also test it
 
1 - 7 of 7 Posts
Top