Impala Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey guys I have a 2003 Impala Ls 3800 I’ve been working on the car since I got it. It’s clunks when accelerating from a stop or turning a low speeds... it’s not all the time tho it’s like it will clunks a couple times then will run fine until I cut car off and start it again.... now I replaced both axles (I DO need axle Seals), Lower Control Arms, passenger wheel hub, inner & outer tie rods, Engine & Transmission Mounts, Dog Bones, MAF & MAP Sensor, Cleaned ThrottleBody, TPS Sensor, PCV Valve & It STILL CLUNKS CAN ANYBODY FIGURE OUT WHAT IT MIGHT BE
 

·
Registered
Joined
·
28 Posts
Discussion Starter #2
I also have a weird clicking or ticking sound but ONLY WHEN WHEELS MOVE... sound like it’s coming from the front... if I drive slow it moves slow if I drive fast it goes fast I check around the wheels and nothing is outta place or anything that’s noise kills me it doesn’t effect the way the car drives it’s just a noise
 

·
Super Moderator
Joined
·
18,404 Posts
Welcome! :beer:

This can be a known issue with the tranny. It could just be modules....



We would like some pics too...:D
 

·
Super Moderator
Joined
·
18,404 Posts
Which modules should I be looking into because I replaced the tranny as well & it still does it when taking off from stop

Odd....a new trans? There are modules just inside a side panel that i have heard of. They control shifting. I had a 2000 that did that, but it would not if I took off slowly.
Not sure what it could be if you replaced the trans and it still clunks....

Anyone else? :dunno:
 

·
Super Moderator
Joined
·
18,404 Posts
1 - 7 of 7 Posts
Top