Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
The front driver speaker on my 2007 Impala ss is not working correctly. The door chime is very soft and not as loud as it should be, and when I play music the driver side speaker doesn't play at all. Every now and then, the speaker will play for a few minutes then cuts back off. As the speaker is on, the chime volume is working fine. Any suggestions?

from my ADR6425LVW using AutoGuide.Com Free App
 

·
Registered
Joined
·
954 Posts
Black-magic, I realize you're seeking DIY advice from owners, but I wanted to jump on this thread quickly to let you know I'm available via private message if you would like any assistance working with your Chevrolet dealership. I do recommend having their technicians run the proper diagnostics on your Impala, and I'm happy to call them on your behalf.

Best,

Katie
Chevrolet Customer Service
 

·
Registered
Joined
·
17 Posts
For others, looking for answers, you may want to open and close the drivers door while the chime is supposed to be sounding. If moving the door makes a difference, suspect a broken wire in the harness to the door.
 

·
Registered
Joined
·
4,122 Posts
I would check the wiring seeing how it works sometimes and sometimes it doesn't. My old car had that issue and the wiring was stripped of insulation and was arching out.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
185 Posts
That EXACT thing would happen on my '07 SS. If the outside temperature got below 50, the speaker would go soft or cut out entirely.

Replace the door speakers. These GM speakers are known for doing this.

I put some nice Kenwoods in mine and the problem was solved.
 
1 - 6 of 6 Posts
Top