Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I just installed a throttle body spacer, tstat 180 degree and al 104's spark plugs on my 04 impala SS. Now my check engine light is on. I brought it to auto zone to hook it up on the obd reader. The reader gave me a code which is p0171 according to auto zone on there computer that code meant that the, "pcm has determined that during the testing, the fuel system for bank 1 was too lean." then if you read further down it says, " the power train control module uses the oxygen sensor to calculate the air/fuel ration of the engine. the computer has recognized a rich or lean condition on the one engine bank only."

When I installed my throttle body spacer I had to disconnect the mass air flow sensor and the other plugs that connected to the throttle body. I plug them all back in like it was. I even disconnected my battery for 30 minutes once I reconnect the check again light appears right when I turn my car on theres no delay....any idea's what the hell is going on...thanks
 

·
Registered
Joined
·
2,102 Posts
Bad O2 sensor. Or possibly a leak in the intake system somewhere, make sure all the clamps are tight.
 

·
Super Moderator
Joined
·
7,057 Posts
I would reset the lamp by the code scanner. It is not uncommon to pole the computer and then reset the system and see if it picked up an anomolly or if it come back on with the same code then there is an actual problem.
 

·
Registered
Joined
·
3,391 Posts
no idea why those mods would trip a lean code, you did use the gaskets on the TB spacer right?
PS see if you can get a hold of one of the MassHoles, I know a few of them have DHP/Powertuner they use to tune codes, they may be willing to scan your car for you while driving
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
no idea why those mods would trip a lean code, you did use the gaskets on the TB spacer right?
PS see if you can get a hold of one of the MassHoles, I know a few of them have DHP/Powertuner they use to tune codes, they may be willing to scan your car for you while driving

Ya I got a new gasket for my throttle body and the the throttle body spacer came with gaskets and there installed perfectly. Autozone refuses to reset the code beacuse it has to do with emissions even though I just got my inspection sticker last month and im good for another year. I found that if I disconnect my battery for more then an hour. So far the light has not come on yet...
 

·
Registered
Joined
·
1 Posts
Which 02 sensor would trip the code for bank1? Have the same problem with my 04 SS but no mods other than K&N cold air intake. Code came up 7 months later so don't think it is related. Been driving with it for a while. No performance issues other than rough idle sometimes. Sometimes will actually turn off by itself but then come back a few days later.
 
1 - 6 of 6 Posts
Top