Impala Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
this has hapened twice to me in the past 2 weeks and its confusing me... When i take the key out of the ignition step out to walk away a fan of some sort remains on... any ideas?
 
G

·
This is typical it usually means your temperature is reading 0 and you need to change your thermostat my did it till i changed the thermostat, A temp fix until you change it is to go under the hood and find the 25 watt mini fuse marked pcm and pull it then put it back that will stop the fans but your car will start hard the fist time after to relearn pcm.
 

·
Registered
Joined
·
1,556 Posts
thermostat is one of the easiest upgrades on any car usually around 30 like stated b4:biggrin:
 

·
Registered
Joined
·
657 Posts
what engine do you have? the 3400 t-stat is a PITA to do, but i think its a little easier to do on the 3800. while youre at it, get a 180* t-stat instead of the stock 195*. also, these can be bought at autozone or similar for about $10.
 

·
Registered
Joined
·
657 Posts
what year is it? have you changed your LIM gaskets yet? may save yourself some time and money down the road to do it all together. its an all day job, but most mechanics are going to charge you anywhere from $700-1200 for the labor. i would do it all at once, since the t-stat is such a pain to do anyways on the 3400. might as well get the new redesigned LIM gaskets in there while you have it apart. if they arent leaking yet, its just a matter of time until they do.

EDIT: i see you have a 2000. check out your LIM gaskets and see if they are leaking. if they are not leaking externally, there is a chance that they are leaking internally as well. look at the underside of your oil filler cap. if theres a milky substance there, you have faulty LIM gaskets. also, look for the notorious dexcool sludge in your cooling system (rad cap, overflow bottle, hoses, etc.)
 
1 - 8 of 8 Posts
Top