Impala Forums banner

1 - 4 of 4 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
So I'm cruising in the city, when all the cars in front of me suddenly started braking fast....I slammed on my brakes and the ABS kicks in as it should and worked great....there were no accidents or anything just another day in city traffic, well when I came up to a light and pressed on the brake again....the peddle went down a little further then before in order to stop and my ABS light as well as the traction control light came on. The car does break, but you pretty much have to floor the peddle. I'm back home now, and there isn't a nearby brake shop or caddy dealership nearby, is there anything I can do to fix this....could the system need resetting or something?

So far I have bleed the brakes and disconected the battery but no change.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Don't ask us losers and no bodies that rly dont no anything, go 2 a mechanic d a m n e t
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Ugh...this could mean so many things. Try taking ABS fuse out and drive car around the block a few times (brakes will work fine), then reinstall fuse and test drive. If you still have problems you are going to have to take a trip to Mr Goodwrench. ABS pump is sealed unit with nitrogen pressurized system -- possibly something inside unit let go causin fault. Or...could be a bug in the electronics and may be able to be cleared-up in seconds. Traction control works off ABS system -- when ABS faults, traction cntrl defaults 'off'.
 

·
Super Moderator
Joined
·
7,057 Posts
Best have the car checked. It could possibly be that the master cylinder is bypassing inside it self. This will cause the spongy peddle and set off the lights. As stated earlier get this check out by someone whom know the brake and traction systems.
 
1 - 4 of 4 Posts
Top