Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1 (Edited)
1 of the 4 bolts on the rear engine support thing snapped when i tried to vtighten it, it was weathered and all the rest were really loose i gave it a little tug and it sheared off, what is there to do and should i be concerned about this?

edit: its the bar connecting the left side to the rightside just above and behind the engine
 

·
Registered
Joined
·
64 Posts
From strut mount to strut mount? ie. strut brace?

Pull it out and take another one of the bolts to AZ and get a new one.

If you can,grip the broken bolt with some vice grips and twist it back out.(let some good penetrating oil soak in it first)
If you can't get it out that way,drill a small hole in the middle of it and use an extractor(available from AZ).

Not sure how much difference it will make-regardless if it's broke fix it is my motto..
 

·
Registered
Joined
·
557 Posts
Youv'e got a bit of a problem eh? As Defeddie said, soak it in penetrating oil. I prefer PB Blaster, and I would leave it soak over night. My guess though is it might be hard to get to it to get the vise grips on it. Worst case you're gonna have to pull the strut out to get to it. But you'll have plenty of room to work.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #4
it sheared off lower then the surface... yeah its the strut mount to strut mount bar. i dont have the tools for the strut removal and since its the reverse side of the bolt (i.e. the nut and thread portion) is can i just drill the bolt out and screw another into place? as if its a larger size and just screw it into the metal itself
 

·
Registered
Joined
·
557 Posts
theres no special tools to remove the strut assy, and you can take the assy to a shop and they'll swap out the strut mount for you
 
1 - 5 of 5 Posts
Top