Impala Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
hi guys.
my battery is dont charging on my 1970 impala.
i dont know why and it makes me very :bang:
i have only 2 wires in my generator.
and my horn isnt working.
the owner before made a button on the dash for the horn. the steering wheel horn istn working.
an my GEN light is all the time on.
i drive 30miles and the gen light is all the time on :(
i hope for an answer.
thanks
 

·
Registered
Joined
·
170 Posts
Grab a volt meter, start the car and see what voltage is coming from the generator. Sounds like it's junk and needs a rebuild. Also sounds like the previous owner was a back yard guy and just through things together to just get by and not fix it right.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
hey, i have a voltmeter but i gave it an friend and yes,... he dont know where it is...
have anyone a wiring diagram for the generator/alternator?
the owner before was a bastard
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
hey guys
look at the pictures please.
iam 100% sure, that there is a wiring problem.
the owner before make so bull****.
look at this
there are only 2 wires in the generator.
and i havent a good wiring diagram for it.
 

Attachments

·
Registered
Joined
·
23 Posts
Discussion Starter #6
it think i got it.
i charged my battery for 14 hours or like that and it shows me 8,5 volts. İ connect it to the car and the car dont start.
İ start my car with another car and power wire from battery to battery and my car start.
İ let it idle for 1 minute and during it idle, the battery shows 14 volts.

Good that means, alternator is good but battery is dead. Damn.
Wich amper battery do u suggest me?

By the way. thank u very much to everybody who help me
 

·
Registered
Joined
·
1,404 Posts
it think i got it.
i charged my battery for 14 hours or like that and it shows me 8,5 volts. İ connect it to the car and the car dont start.
İ start my car with another car and power wire from battery to battery and my car start.
İ let it idle for 1 minute and during it idle, the battery shows 14 volts.

Good that means, alternator is good but battery is dead. Damn.
Wich amper battery do u suggest me?

By the way. thank u very much to everybody who help me
here you go
Battery Selector click on the Submit button to show your battery choice
 
1 - 7 of 7 Posts
Top