Impala Forums banner

21 - 37 of 37 Posts

·
Registered
Joined
·
173 Posts
My 2013 has this issue,really annoying for a few seconds.I did not have it looked at while it was still under the bumper to bumper warranty.
 

·
Registered
Joined
·
4 Posts
I have an 2012 Impala LT and I have this issue too. It seems to be getting worse and each time I take it to the dealer they will show me that TSB and will refuse to even touch it. My Impala will rattle for at least a minute when I start it up and I hear this rattle while I am driving down the road as well. Does anyone else experience this issue to the extent that I do?
 

·
Registered
Joined
·
45 Posts
My 2014 LTZ makes this rattle noise for about 6 seconds after start on cold mornings. I have never heard this on the road. My previous 09 LT had no noise on start and the engine seemed completely isolated from the body.
 

·
Registered
Joined
·
4 Posts
I have yet to find a case like mine on the internet. Literally anyone that hears my car says that it sounds awful and I should get it fixed. I also would like to add that I had a minor front end collision over this summer only after which the problem developed. I took it to one shop that told me it was the spring in the downpipe where the exhaust meets the engine and would cost almost $500-$600 to replace with labor included. However, my preferred shop that I bought the car from simply rubs that dreaded TSB in my face and says it is the y-pipe. My intention was to get whatever is broken replaced under warranty to avoid paying through the nose for such a little thing. Anyone have some suggestions because I am almost out of options here?
 

·
Registered
Joined
·
4 Posts
I would, but I am not in a position to do that at the moment. For the time being, I guess it is something I will have to deal with unfortunately. It just kind of sucks I buy a nearly brand new vehicle that makes an awful noise and GM tells me "Oh it just does that."
 

·
Super Moderator
Joined
·
12,432 Posts
I agree completely... Actually, have you tried a different dealer? Sometimes, one dealer will address an issue that another won't. It should not be as bad as you are talking about. I've never even heard it at all on my 2012 LT (38k miles).

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
4 Posts
I have only tried that one that mentioned the downpipe. I might try another when I have the time just for the heck of it to see what they say, wouldn't hurt. I will keep you updated on what happens. Thank you for the insight!
 

·
Registered
Joined
·
1 Posts
I have the 2012 Base model Impala (bought new) and the rattling noise is always there, but most noticeable upon acceleration. It's really annoying and I've been to the dealer several times. They could not fix it, although they did say it was there and the service manager drove with me and thought it was something serious at first. My local mechanic thinks it's normal. I have owned several cars and none made this weird rattling, banging sound. I test-drove a 2008 Impala with the old engine and it was smooth and quiet. The 2012 received a new 6-cyl and a new exhaust and tranny, so I imagine that's why the 2012 and later have this problem. I don't like the 2012. The seats had been redesigned in 2009 and are not comfortable like the '06-'08. The suspension is too hard, the engine and tranny are too noisy and not relaxed.
 

·
Registered
Joined
·
43 Posts
Mine had this problem when i purchased my 2014 ltz limited with 37000 miles on it and took it to the dealer and they said it was the resonator and replaced the whole muffler system for me for $100 because they felt bad and it was the 3rd car i bought from them and now the problems gone!
 

·
Registered
Joined
·
8 Posts
My 2012 LTZ does not appear to make the noise or maybe I just do not hear it. It has a little over 63k miles on it so far, drives well. I personally like the stiffer suspension and the seats are not bad, but then my dd is a 2012 Sonic LT.
 

·
Registered
Joined
·
79 Posts
5 Year Update

Since we were all told by GM this is normal and no fix was required, is there anyone here that still has this annoying noise on startup?

Has it gotten worse over the years or still the same?

Do you experience the slight rattle during regular driving?

Has anyone replaced the exhaust and if so, did the problem return with the new exhaust?
 

·
Registered
Joined
·
369 Posts
Since we were all told by GM this is normal and no fix was required, is there anyone here that still has this annoying noise on startup?

Has it gotten worse over the years or still the same?

Do you experience the slight rattle during regular driving?

Has anyone replaced the exhaust and if so, did the problem return with the new exhaust?
I've had the noise since I bought the car two years ago. It still hasn't changed at all or gotten worse. Only lasts for a few seconds on start up, when the engine is cold. Never heard it while driving. While mildly annoying, I never looked into getting it fixed.
 

·
Registered
Joined
·
629 Posts
Since we were all told by GM this is normal and no fix was required, is there anyone here that still has this annoying noise on startup?

Has it gotten worse over the years or still the same?

Do you experience the slight rattle during regular driving?

Has anyone replaced the exhaust and if so, did the problem return with the new exhaust?
Yes, mine does this also... cold start up for about 5 seconds. Doesn't happen again after this. Haven't bothered with fixing it but I may do it down the road. Not really annoying enough yet. Still running full stock exhaust system.
 

·
Registered
Joined
·
987 Posts
Found the offending noise maker on my 2012 Impala. Short flex section just behind the bend over the cross member.
See attached images.
Replace with new flex by my local exhaust shop, ~$150.
No more noise...
In the crossover pipe between the exhaust manifold flanges??? That's a strange place to put a flex section...

Why not after the wye?
 

·
Registered
Joined
·
1 Posts
outlawarrior is correct. I went under the car, had someone turn it on to verify where the rattle was coming from and that small flex was the culprit. Took it to a muffler/exhaust repair shop. $120 and about a hour and a half later. My life was free of the annoying and embarrassing rattle we've all been getting on a cold start.
 
21 - 37 of 37 Posts
Top