Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I recently picked up an 03 Impala. I put an engine in it and now I am trying to shake out any bugs it has. When I turn the a/c on it is nice and cold coming from the passenger side vent, but when I feel the driver side vents the air is coming out, but it is warm. What gives? Is there some sort of air mix valve that is sticking? If so where would it be located? The car in question is a base model 03 Impala with a 3.4 engine. Thanks for any help.
 

·
Registered
Joined
·
195 Posts
what i found with mine is that it was my A/C Compressor. i just changed it this morning and now all is well. good luck.
 

·
Super Moderator
Joined
·
7,057 Posts
These cars use a computerized blend door motor system. Most cases of this problem is that one of the blend door motors has failed. When you have cold air on one side and not the other that generally means the AC compressor is in fine shape and the problem is elsewhere. Not sure where the blend door for the drivers side is but you will find it under the dash. Search this forum for there are many threads on this topic and some will have the location of the blend door motors for you as well.
 

·
Registered
Joined
·
195 Posts
i agree with ya 77Impala, it was just the case with mine. my passenger side blew cooler than my drivers side...not to mention i had a very tiny leak in my compressor. but when i changed the compressor both sides blew equally cold. it was just my case, ionno.
 
1 - 4 of 4 Posts
Top