Impala Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Transmission problem
1995 Chevy Caprice V8 Two Wheel Drive Automatic 158000 miles

I have a 1995 Chevrolet Caprice LT1 350 5.7L. While my foot is on the pedal I am able to accelerate and change gears. But when I lift my foot off of the pedal to slow down and press the pedal again to accelerate, it will not accelerate. The only thing will happen is the engine will just get louder as if Im going faster but Im not. The only way I can get back to accelerating is if I go under 20 mph and start over. I checked the transmission fluid level, and its red and full. I also have another problem, when my engine get hot the fans do not come on. I changed the sensor and the relay switches but they still do not come on. Right now, I have the fans staying on all the time by unplugging the plug from the sensor. Can you please help me find out whats the problems?
 

·
Registered
Joined
·
55 Posts
Check Engine Light

Is your check engine light on at all? If so, do a computer diagnosis on your vehicle.

I went to Aamco transmission and they charged $39.99 to do a computer diagnosis.

Your problem could be and I am not for sure but the TPS.
 

·
Super Moderator
Joined
·
7,057 Posts
Have the transmission checked. The engine speeding up but not the tranny indicates something in the tranny has shifted to neutral instead of downshifting. Then when you drop below 20 MPH it catches and is ready to go again.

Maybe tomorrow Angel from George Bates Automotive can chime in about the radiator fan problem, he is more familure about those cars.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
If my transmission fluid is red but smell burnt, will it help if I just change the transmission fluid.
 

·
Super Moderator
Joined
·
7,057 Posts
I doubt that it will help. You could try it but I would not get my hopes up that it would work.

If you do you may want to try a Transmission treatment with the fluid flush. Problem is that it in some cases it could make things worse than better. But right now your transmission most likely needs to be rebuilt.
 

·
Registered
Joined
·
102 Posts
Yep, your tranny is more than likey toast. You could spend the bucks to have a trans fluid flush, but only if you experienced a little slippage. Even then, it might prolong it a couple thousand miles, till you get another one. But then it's risky at this point, bcuz it might not do you any good. Get it checked out by a tranny guy
 

·
Super Moderator
Joined
·
7,057 Posts
Just confirms the problem is in the "D" and/or "OD" portion of the transmission. I am afraid it is ready for an overhaul. WIth this problem continuing to drive it will only agravate the problem and cost you more by replacing more parts that wear or break. I speak from experience.
 

·
Registered
Joined
·
1,556 Posts
yup anyone familiar w the 460ole trans will tell you they are shit after about 100000 just to much power w the lt1s lmao !!!!!!! my car has 229 thousand and shifts ok knock on wood but i am expecting a rebuild soon
 

·
Banned
Joined
·
3,667 Posts
A 95 will rarely throw out a MIL/CEL so do this....plug the sensor on the waterpump back in so that you do not have a hard start everytime. Now, start the car and turn on the A/C and check to see if you have one/both of the fans come on. If nothing happens after a few minutes, Shut off the car and apply direct power to each fan and see if it engages. If nothing happens, get some new fan motors.

Also take a heat gun and verify that the engine is actually getting hot.

As for your trans, do not flush it....flushing it typically causes more problems than it fixes however in your case, your trans is already dead. Take it to a trans shop and have them test the servos before doing anything else.....you may find that a bad servos or 2 will make your trans seem like it is totally dead. Replacing these should cost around 2-300 dollars parts and labor included IF THEY NEED REPLACING. If you opt for rebuild......check ebay, there are 3 GM rebuilt 4L60-e's on ebay for dirt cheap with shipping included from a GM dealer who built them with shift kits and the buyer backed out.
 

·
Registered
Joined
·
624 Posts
from other posting ive read ,for some reason tranny shops seem to f/up these 4l60e when they rebuild them , works fine few awhile then sh8ts the bed and then u need to do battle with them warrenty or not,if u get one with a shift kit u should get ur pcm reprogramed, but again im no expert in this area
 

·
Banned
Joined
·
3,667 Posts
My point was and is....get a GM reman..... even at the dealer, parts and labor come to around 1900 and that is a steal considering the warranty is 3-5 years/100,000 miles and good at any dealership.
 
1 - 13 of 13 Posts
Top