Impala Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Have had car for about 500 miles now, and noticed this the other day.

Anyways, the car seems to be running a little warm. It goes up one tick over the halfway mark on the temp. I am thinking it could be thermostat and possbily need a coolant flush?

The heat worked before this happened and now it sometimes works and sometimes it doesn't. Doesn't really seem any pattern besides that it goes up about one tick and then back down to the middle mark.

The radiator fans are running at the time. I could hookup a scanner and get the actual temp and see if there are any hidden codes with the tech2.

My 2011 never went over the halfway mark but this 07 did it the last couple days but always goes back down.
 

·
Registered
Joined
·
1,317 Posts
possible sticking thermostat, check fluid level and replace the tstat. they seem to be hit or miss on quality for these cars. go with a quality unit and see how it responds.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #4
Coolant level is fine in the tank.

Okay I am going to try at 185 thermostat and probably go ahead and flush the whole system this weekend.

Flushing it I mean.

1. Drain radiator from petcock valve, fill with water.

2. Warm engine to normal temps.

3. Drain again and fill with water.

Do steps 1-3 until water is coming out fairly clear. I usually have to do this 2-3 times and takes some time.

4. Fill with coolant, I will probably keep using dexcool as thats what has been in there. I will replace thermostat too.

I am just confused, as I believe I should replace the thermostat after the flushing is done vs doing it beforehand.

Hoping that I can get this all done this weekend and then sell the car as I am fairly tired dealing with it. I have a 09 G6 GXP with 80K miles for 2500$ waiting for me ;D
 

·
Registered
Joined
·
1,317 Posts
i take my cars in for the flush, less mess on my property then. since they have the fluid drained it was only 120 at the shop i chose for the flush and thermostat. for me that was worth the effort/price. just putting it out there.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #6
i take my cars in for the flush, less mess on my property then. since they have the fluid drained it was only 120 at the shop i chose for the flush and thermostat. for me that was worth the effort/price. just putting it out there.

I understand, but two or three hours in time, and it costs me 15$ for a jug of 100% coolant you mix with water and 20$ or so for a thermostat.

My shop/dealership cost 100-150$ for just coolant flush the thermostat is a different story.
 

·
Registered
Joined
·
2,386 Posts
^ Many locales allow used coolant to be disposed of into the sanitary sewer system. It's allowed here in KCKS. Might check.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #9
^ Many locales allow used coolant to be disposed of into the sanitary sewer system. It's allowed her
e in KCKS. Might check.

Yeah something like that. Anyways it will get put into 5 quart jugs and disposed of when the time comes. I have roughly 20 of them out back full of oil and coolant that gets disposed of.

Anyways the Crossover gaskets are leaking I believe. Big issue on the 3.5s I think. My G6 had to have them done at 120K and another G6 at 110k. The tank isn't low for coolant but I will be replacing the thermostat and flushing the system this weekend hopefully.
 

·
Registered
Joined
·
2,801 Posts
Anyways the Crossover gaskets are leaking I believe. Big issue on the 3.5s I think. My G6 had to have them done at 120K and another G6 at 110k. The tank isn't low for coolant but I will be replacing the thermostat and flushing the system this weekend hopefully.
I did them on my G6 3.5 (LZ4) as well. It was fairly straightforward. Not nearly as involved as the lower intake gaskets on the 3.4 (LA1).

Doug

.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #11
I did them on my G6 3.5 (LZ4) as well. It was fairly straightforward. Not nearly as involved as the lower intake gaskets on the 3.4 (LA1).

Doug

.
Those were not so bad honestly, a alternator, power steering pump, couple pulleys and couple more bolts and they were off. The intakes scare me.
 
1 - 11 of 11 Posts
Top