Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The issue started couple of months back when i was driving back from boston to atlanta. Car used to have vibrations suddenly when on cruise control. I didn’t think much of it then but slowly since two months the vibrations started happening even at 45mph in local roads when following traffic and vibrations can be stopped when i downshift manually from 6 to 5th gear and rpm would go above 2000 rpm. I noticed that vibrations only happen when at low rpm and high gear, basically if I’m cruising or following traffic with feather footing my accelerator pedal.

well i got tired of this at took it to dealership with only 42000 miles thought i would get repaired under warranty.

Delearship had it for couple of days and here’s what the tech wrote, did all the work under warranty. No cost to me.
  • Found shudder in 4th gear only, replaced valve body according to service bulletin #18-na-358 doc #5170493
  • trans fluid flush with devron 6 of 8qts.
QUESTION, Is this one off problem or should i sell this to dealer as i wouldn’t want to end up with lemon at aroung 80,000 miles. Is the issue going to resurface again?

any feedback from senior members is highly appreciated. Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3

·
Registered
Joined
·
1,654 Posts
Well, do you think the issue is gonna come up again in future.


I’m not sure. The TSB applies to multiple year models, so there must have been enough complaints for the engineering / power train group to determine what was causing the shudder. I suspect this fix is a good one, as it involves replacing two valve bodies.

I own a 2014 Impala 2LTZ, purchased new, and have not had this issue with the transmission. It now has 50,xxx miles on it though.
 
1 - 4 of 4 Posts
Top