Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Need help with occasional AC problem. Works fine most of the time but then on occasion air flow almost stops. When this happens I can turn the fan on high and here it run on high, but there is little air flow. It's as if something is blocking air flow. The dealer has looked at it several times and cannot find the problem. Of course it works fine when they look at it. When this happens I can usually fix it by stopping the car are for 5-10 minutes and restart. Then it usually works fine. One thought was that the coil was freezing up, but they checked the refrigerant and is was fine.
Any ideas????
 

·
Super Moderator
Joined
·
18,404 Posts
Welcome!!! :beer:

Pics of the ride please!:angel
 

·
Registered
Joined
·
1,425 Posts
Need help with occasional AC problem. Works fine most of the time but then on occasion air flow almost stops. When this happens I can turn the fan on high and here it run on high, but there is little air flow. It's as if something is blocking air flow. The dealer has looked at it several times and cannot find the problem. Of course it works fine when they look at it. When this happens I can usually fix it by stopping the car are for 5-10 minutes and restart. Then it usually works fine. One thought was that the coil was freezing up, but they checked the refrigerant and is was fine.
Any ideas????


Have you checked the HVAC air filter? How many miles on the vehicle? It is possible you have a mouse nest inside the ductwork (on top of the HVAC air filter) which is blocking airflow.

Good information with pictures here: http://www.impalaforums.com/diy-how-to-s-and-write-up-s/543929-2014-impala-cabin-filter-replacement.html

I own a 2014 Impala 2LTZ.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
40,000 miles now, but problem started around 15,000 miles. Yes, cabin filter has been changed, and most of the time it works fine.
 
1 - 4 of 4 Posts
Top