Impala Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 2014 Impala 96k mikes new body style. The other day the “service power Steering” warning came on out of no where. No power steering at all. Can still drive it just is a bear.
No idea where to start looking. No check engine light. Can’t find anything on YouTube etc. Checked for recalls, nothing.
Anyone with any ideas where to start to diagnose it?
Thank you!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
53 Posts
I have a 2014 Impala 96k mikes new body style. The other day the “service power Steering” warning came on out of no where. No power steering at all. Can still drive it just is a bear.
No idea where to start looking. No check engine light. Can’t find anything on YouTube etc. Checked for recalls, nothing.
Anyone with any ideas where to start to diagnose it?
Thank you!


Sent from my iPhone using Tapatalk
Are all of your parking sensors working?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Hi. Yes they work. However, now the front camera says service. This is new.
Thank you


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
53 Posts
Hi. Yes they work. However, now the front camera says service. This is new.
Thank you


Sent from my iPhone using Tapatalk
My power steering issue was caused by a wheel bearing. There is a recall for your model year regarding the power steering control module. You should contact a dealer and see what they say.
 
  • Like
Reactions: 1999 White C5 Coupe

·
Registered
Joined
·
1,617 Posts
I have a 2014 Impala 96k mikes new body style. The other day the “service power Steering” warning came on out of no where. No power steering at all. Can still drive it just is a bear.
No idea where to start looking. No check engine light. Can’t find anything on YouTube etc. Checked for recalls, nothing.
Anyone with any ideas where to start to diagnose it?
Thank you!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
My power steering issue was caused by a wheel bearing. There is a recall for your model year regarding the power steering control module. You should contact a dealer and see what they say.
I did. My vin isn’t one of the cars involved.
Your wheel bearing, how was that diagnosed? Is that something that would show a code in the correct scanner?
Thank you


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,617 Posts
^ Did you visually inspect the ground and the 100 amp fuse pictured in the recall pdf above?


I own a 2014 Impala 2LTZ, purchased new, that was the subject of the recall.

I seem to recall a TSB also (I don’t have a copy or link) that said the 100 amp power steering circuit fuse was made available as a separate service part.
 

·
Registered
Joined
·
53 Posts
I did. My vin isn’t one of the cars involved.
Your wheel bearing, how was that diagnosed? Is that something that would show a code in the correct scanner?
Thank you


Sent from my iPhone using Tapatalk
Yes, mine showed up on the scanner, but I also lost the guide lines and sensors on my rear camera. So our problems might not be the same. Unfortunately several systems on these cars are all connected to each other, so sometimes it's hard to track down without a scanner.
 

·
Registered
Joined
·
20 Posts
I have a 2014 Impala 96k mikes new body style. The other day the “service power Steering” warning came on out of no where. No power steering at all. Can still drive it just is a bear.
No idea where to start looking. No check engine light. Can’t find anything on YouTube etc. Checked for recalls, nothing.
Anyone with any ideas where to start to diagnose it?
Thank you!


Sent from my iPhone using Tapatalk
Check power and ground wires
 
1 - 12 of 12 Posts
Top