Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hello, I'm a new owner of 2014 Impala LTZ with 98k miles. I love the car so far but have noticed a couple issues.

1) engine stumbles in park/neutral from 1,500 to 1,900 rpm. I've seen a couple other threads on this but no resolution. Does anyone know what causes this?

2) i feel warm air blowing through vents with hvac turned off and the car moving. The ac and heat work fine when turned on. If I turn the ac on and then off, I feel cooler air blowing.

Any ideas?
 

·
Registered
Joined
·
338 Posts
It sounds like what others have described here when the upper intake as well as the valves are carboned up and need cleaning. There are several brands of cleaners available for DIY, or repair shops offer this type of service.
 

·
Registered
Joined
·
126 Posts
My gosh ... 98,000 miles is nothing. You shouldn’t be having any problems with that engine (yet). I would just leave well enough alone and keep driving it, waiting for more information (like a CEL).

As for the warm air through the vents, maybe you’ve got an issue with your Blend Door where it’s allowing heated air from the heater core to bleed through. Check the operation of your temperature knob and how it’s moving that Blend Door. On my ‘02 there are actually two air temp actuators, both controlled by a voltage signal through a resistor. You might have to use a voltmeter to see what voltage is going to the actuator(s) to verify one or both aren’t slightly open to allow the hot air to sneak through.
 
1 - 4 of 4 Posts
Top