Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello All!

We have a problem that we're struggling to diagnose. It's a 2014 Chevy Impala LT, with merely 9600 km on it (yes nine thousand six hundred)

The power steering has completely failed and is not working.

The first time this happened we took it to the dealership. They said it needed a new rack and pinion, as well as a new module. It's no longer in warranty and would cost $3850 for the repairs.

We said we were going to get a second opinion. When we picked it up, the power steering was back. We took it to another shop that was an hour away. About 85% of the way there the message came up again on the dashboard and power steering was disabled once again.

They brought the computer out and found that the code it posted was that the steering wheel was out of position by 40 degrees. So he recalibrated the steering wheel position and it worked great for 300km or so.

Again though, the power steering has failed. Today I tried disconnecting the battery to see if it would clear the code but it's still give us trouble.

Has anyone heard of this issue happening and if so what could we possibly check for. We really don't want to spend $3850!

Thank you!

Nick
 

·
Registered
Joined
·
48 Posts
We have a 16 LT2, has done the same thing but no code as of yet, we shut the vehicle off then restarted it, been fine ever since. Just worries me it's going to do it again, our car had around 52,000 miles when it occurred, now has 56000.
 

·
Registered
Joined
·
425 Posts
I would be looking for a wiring issue before I started throwing expensive parts at it. The intermittent issues makes me feel like you might have a short or something in a wiring harness. I suppose its possible its a bad module? Seems strange it would need both a module and rack though.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Hello all and thank you for your replies.

Took it back to the shop that cleared the code and got us 300-400km on it. They pulled the ground off and removed all paint to avoid grounding issues as defined in the recall.

I also bought myself a bluetooth odbii reader and I already have torque so I should be able to see any faults that come up.

In reading around I had noticed the wheel sensor was a weird one that was triggerring a similar issue so that will be next for sure.

We will get it back tomorrow and just need to drive it to see if the problem comes back.

Fingers crossed.
 
1 - 5 of 5 Posts
Top