Impala Forums banner

21 - 30 of 30 Posts

·
Registered
Joined
·
280 Posts
Discussion Starter #22
I went to the junk yard this morning and got another fuse box. After swapping them out I started the car and and everything worked. No check engine light, Windows, seats and door locks worked. Engine ran great. Thought I would let it run awhile while I taped up some wires. After about 5 minutes running it just shut off and will not start back up. It turns over but will not start. What ever happened threw the following codes P0178, U0109, P1400 and P057D. Not sure if it had anything to do with the wires I was taping or not.
 

·
Registered
Joined
·
2,677 Posts
Fwiw, p0178= fuel composition sensor circuit low input. P1400= differential pressure feedback egr (dpfe) sensor circuit low voltage detected.
 

·
Registered
Joined
·
204 Posts
P0178 Fuel Composition Sensor Circuit

U0109 Lost Communication with Fuel Pump Control Module

P1400 Cold Start Emission Reduction Control System

P057D Brake Pedal Position Sensor Circuit High Voltage Signal
 

·
Registered
Joined
·
280 Posts
Discussion Starter #25
It seems like it is fuel related. We are having a tropical storm go through so today and tomorrow the weather is terrible. Will not have a chance to look at it until friday.
 

·
Registered
Joined
·
280 Posts
Discussion Starter #26
Was out checking fuses this morning and noticed the engine compartment fuse box I took out had a fuse the new one does not. After looking up the fuse legend it said FSCM (fuel system control module). So I put the old fuse box back in and the car started right up and ran great. However now I am back to my original problem with no power from the battery 2 fuse. There is no prongs on the new fuse box to hold a fuse at the FSCM spot. One question if anyone can answer, How did the engine run for nearly 5 minutes when I first changed the box without this fuse? I guess I am going to have to find another fuse box that has the FSCM fuse. In the pictures its the 15 amp above the fan relays. IMG_1983.jpg IMG_1984.jpg
 

·
Registered
Joined
·
280 Posts
Discussion Starter #28
FSCM is used on '12 & up Impalas & Limiteds. Only the fuse box from those years are compatible.

BTW, did you check your BATT2 fuse?
I am embarrassed to say I did but it looked good. Thought I would change it just to see and yes it was a bad fuse. Wish I had done that at first and would have saved myself lots of trouble. I know now that a fuse can look good but still be bad. Anyway everything works now. Thanks to everyone who responded for your help.
 

·
Registered
Joined
·
280 Posts
Discussion Starter #30
I could swear I thought I checked the blade at the BATT2 fuse location when I had the fuse box apart. I remember using a test light on it and having no power there. Knowing me though I probably had the battery disconnected to change the fuse box.lol. I was looking at the bad fuse last night and to look at it the filament is not burned in half and it looks like a good fuse. It's headed for the trash can though so it does not ever get confused for a good one.
 
21 - 30 of 30 Posts
Top