Impala Forums banner
  • Hello Everyone! Let us know what you would spend a $50 Amazon gift card on, HERE For a chance to win a $50 Amazon Gift Card!
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all!

Just getting in to repairing my car on my own and I am glad to have found you all on this forum. All the past post have been very helpful, but I haven't been able to find anything on this issue.

In short:

My 2010 sunroof fuse repeatedly blows with no other electrical issues on the car.
Where could the short be to cause this isolated fuse to blow?

The whole story:

I have a 2010 LTZ that has never had any electrical issues at all, except that the fuse for the sunroof keeps blowing. I had been ignoring it until I would go to the dealership for my yearly inspection (Buffalo, NY), and then they would just replace the fuse, but that would never last more than a few days or weeks at most. Eventually I asked the shop to take a deeper look while my car was still under warranty, and they said they found some issues, but got the motor and everything in the sunroof replaced to fix it.

Fast forward a few months and I'm still blowing fuses like before.

I'm planning on taking everything apart and looking over the wiring harness on my own to see if I can spot anything, but I'm wondering if anyone has an idea on where to start or what an obvious source of the short might be?

I have no leaks (at least that are visible on the inside of the car), and the drains are clear.

Thanks!
-Cam
 
1 - 1 of 1 Posts
Top