Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
We have a 2008 and the locks both by the door switch and the remote will not work. When activated you hear q noise at all locks and each one moves a "bit" but will not come up at all....are all 4 actuators the problem? I have checked the BCM and there is no problem with that
 

·
Registered
Joined
·
403 Posts
Did they all stop working at the exact same time? If so, that would be odd. If they all stopped working within a month of each other, it would be slightly strange, but likely the door lock actuators. They typically fail somewhat close in time with each other. They typically start to slowly stop working as the temperatures increase, and eventually won't work at all. If all 4 stopped working at once, I would be thinking it was a different issue, although nothing comes to mind as to what that issue would be.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I do not know.... We bought the car a few months ago and it was like that when we bought it..... Never dealt with anything like this before and looking for a remedy..
 

·
Registered
Joined
·
403 Posts
I do not know.... We bought the car a few months ago and it was like that when we bought it..... Never dealt with anything like this before and looking for a remedy..
Ah, okay. It is likely all 4 door lock actuators are bad then. It is sort of a known "issue" with these cars. I think the oem replacements are pretty expensive so most people don't seem to fix them. Not sure if there are aftermarket cheaper options for them or not. Think there are youtube videos showing how to replace them if you feel up to trying it yourself.
 
1 - 5 of 5 Posts
Top