Impala Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I was a die hard Ford driver for most of my adult life, after hearing over and over about how great the Impala was I decided to buy one.
After 4 years I have experienced about as much as I can take. From a transmission slips, which I hear is fairly common, to a fan motor that "growls" in rhythm,(high then low, high the low, etc.) leaking power steering hose / tubing, premature tire wear, (alignments, rotations, and proper pressure always), "check engine" light is on more often than not, Throttle sensor/switch gone bad and now my air conditioner quit working. the only thing I can say is that, knock wood, I haven't been left completely stranded,...yet. I take pretty good care of my investments and regular washing / waxing are the norm for me but yet the bottoms of the door panels (inside) are rusting. Not just a spot here or there, all the way from front to back.
I sincerely hope that I simply got a bad one but I probably will never know because the chance of me buying another one is slim to none. I gave her a good four years and I guess I should expect problems with vehicles from time to time but they just kept coming with this Impala. I'm going to try to get through the coming winter and then it's over, I'm gonna have to put the two horned beast out to pasture.
 

·
Super Moderator
Joined
·
12,441 Posts
Hate to say it, but I've had quite a few issues with my 2012 as well. Only 36k miles and I've already had to replace tires due to a bubble in the tire, replace both front calipers, have HVAC system serviced due to annoying rattle and bad odor, rotors cut twice, ECM and TCM code updated to fix shifting strangeness, intermittent minor transmission slip (very minor and intermittent, but still there), alignment due to steering wheel being off-center, have a loud "clunk" noise from the rear-end when taking off hard from stop if gas tank is full, had an issue with the "axle shaft splines" needing lubrication and also have a rough-idle when stopped with the A/C on!

That is more problems that I've had with all of my previous cars combined - and I'm 41!

Love the way the car looks and like the "open" and "basic" interior though! :)

Not sure if it's because it was previously a rental car or what, but being it's the first rental i bought and I've had so many issues, I'll probably stay away from rentals going forward. Bought the car with only 19k miles on it and it looked brand new.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
811 Posts
Hey jarnos, I also own an 08 impala. Let me reassure you, you aren't the only one with these problems. For me I haven't had too much trouble with mine, but a lot of others aren't so lucky. So far I've replaced an alternator, spark plugs, gas pedal sensor, and a battery. I'm at about 95k (daily driven), but I do need to fix my windows cause they all stopped working, also have a small transmission cooler line leak (cheap fix, just have to replace a c-clip). Other than that she's been kind to me. I'm sorry to hear your having so much trouble with yours. We have to remember these cars were being built when GM went bankrupt.
 

·
Registered
Joined
·
16 Posts
Love it so far.

Although I've had it less than a month I love it so far. The only complaints I had were the rear defroster not working and the fuel mileage isn't what I expected. Got the rear defroster working thanks to some folks on here.
 

·
Four-Seasons Fan!
Joined
·
376 Posts
I still love my 2008 LTZ! Metallic "Red-Jewel Tintcoat", with the Tan/"Neutral" Leather.
I've had the common problems...
* Rear tires cambered in too far. Fixed for free! GM "Goodwill" repair.
* Got 2 new tires free too!
* Moderate oil-use fixed by Chevy too!! Valve-guide seals leaking too much...replaced. Much less oil-burning now...AFM 3.9L Flex-Fuel V6 (LZG RPO).
* Replaced 3 air-handling actuators behind the dash by myself...thanks to help from here!!
* Had a broken ECM (?) ground-wire fixed last summer too.

>>>> Starting/documenting these issues at Dealer while I was still in the CPO-Warranty period saved my hide! Bought the car in Aug. 2011 with 17,000mi. Now has 50,600.
* My rear suspension creaks badly going over larger bumps.
* I'd LOVE to get some Bilsteins back there too...but we're still paying-off my new knee from last Sept.!!

Faron
 

·
Registered
Joined
·
4 Posts
2006 ss impala

I have had my ss since 08 and the only problem I've had was a replacement of the harmonic balancer.That was a grand,on the 5.3 motor.but I love the car.would"nt trade it for nothing.
 

·
Registered
Joined
·
2 Posts
2008 chevy impala

thr
I was a die hard Ford driver for most of my adult life, after hearing over and over about how great the Impala was I decided to buy one.
After 4 years I have experienced about as much as I can take. From a transmission slips, which I hear is fairly common, to a fan motor that "growls" in rhythm,(high then low, high the low, etc.) leaking power steering hose / tubing, premature tire wear, (alignments, rotations, and proper pressure always), "check engine" light is on more often than not, Throttle sensor/switch gone bad and now my air conditioner quit working. the only thing I can say is that, knock wood, I haven't been left completely stranded,...yet. I take pretty good care of my investments and regular washing / waxing are the norm for me but yet the bottoms of the door panels (inside) are rusting. Not just a spot here or there, all the way from front to back.
I sincerely hope that I simply got a bad one but I probably will never know because the chance of me buying another one is slim to none. I gave her a good four years and I guess I should expect problems with vehicles from time to time but they just kept coming with this Impala. I'm going to try to get through the coming winter and then it's over, I'm gonna have to put the two horned beast out to pasture.
 

·
Registered
Joined
·
2 Posts
i am having so much trouble sometimes i cry about it my power steering fluid leaks right out replaced the hose still leaking right out now i figure i need a liner for it but im scared of what it will cost me can someone help me out
 

·
Registered
Joined
·
59 Posts
Transmission issues on my 09 ltz. It only has 79,000 miles on it..It drove great the first week,then I changed out the old fluid for new at my dealership,then it starts slipping when starting from a dead stop ,but shifts fine into second and so on. I can't afford a rebuild so looks like my local salvage yard if it needs replaced,lol.That's what a guy wants to hear after dropping his coins on a car,lol. I love my impala,it feels like good quality and is great shape. I don't blame gm as I know that even tho I have some records on maintenance,i don't know how it was treated through the years by other owner. It just sucks being on a fixed income and i make two pay checks and have dug myself out of a financial hole and it's the first car for myself not purchased off craigslist lol. But I may be jumping to conclusions as I haven't heard back from the shop yet to get an estimate. But just going on what I've heard and it sounds like ill be going to that salvage yard,lol.
 

·
Registered
Joined
·
1 Posts
I have a 2013 and I got it at 43k miles i was screwed on price at 26k for it. In2015. Interest rate at 29.9 worth only 15k when i hot it. Then I found out I had bad arms and tires and shocks all around. Then at 88k miles the crank went out. And the trans started acting up after that. Have had nothing but issues. Then my right side heat control went out and radio messed up. I got a big crap fest for the price of a brand new one.
 
1 - 10 of 10 Posts
Top