Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 2008 chevy impala v6 3.5 with 203,000 miles on it .have 3 seperate issues needing advice on how to fix . i had a check engine light come on about 3 weeks ago checked it with a obd reader and it came up as a large evap leak .so therefore i am having a hard time figuring out the problem and getting it to pass smog . The second problem i have is that after driving around even just for a few mins i get out of the car and there is bubbling coming from the coolant reserve tank and have within the last few days noticed that i have developed a leak but the temp gauge does not show the car as running hot nor has smoke been bellowing out from under hood .i need to know suggestions on what i should do for this ., the 3rd and final problem is when i went to start it today it seemed like it was more of a struggle for it to turn over and felt like the engine was shaking starting it . i didnt leave the car running and have since then haven't even attempted to start it again . I really like my car for the most part it has driven really good for me and i want to keep it going for as long as i can .I am asking because i dont want to mess up the car by running it like this but i dont want to have to spend hundreds of dollars i dont have taking it to a shop . so if there is ways that i can pinpoint the problem and do whatever research to read up and fix it myself then i would prefer to do it that way . Any advice or suggestions would be greatly appreciated
 

·
Registered
Joined
·
160 Posts
The bubbling could be coming from a partially or completely inoperative thermostat. Because it's not showing it's running hot could mean that the temp. sensor is faulty. Another issue is that the fans are not coming on as they should to cool the engine. Vacuum leaks can be tough to find sometimes and are labor intensive. The engine struggling to start could mean a weak battery and the engine shaking could be a bad engine mount. I offer these as ideas just off the top of my head and each issue could be something entirely different...these are just my initial thoughts. Honestly, I believe you'd be better off to find a shop that you trust and have it diagnosed.
 

·
Registered
Joined
·
1 Posts
i have a 2008 chevy impala v6 3.5 with 203,000 miles on it .have 3 seperate issues needing advice on how to fix . i had a check engine light come on about 3 weeks ago checked it with a obd reader and it came up as a large evap leak .so therefore i am having a hard time figuring out the problem and getting it to pass smog . The second problem i have is that after driving around even just for a few mins i get out of the car and there is bubbling coming from the coolant reserve tank and have within the last few days noticed that i have developed a leak but the temp gauge does not show the car as running hot nor has smoke been bellowing out from under hood .i need to know suggestions on what i should do for this ., the 3rd and final problem is when i went to start it today it seemed like it was more of a struggle for it to turn over and felt like the engine was shaking starting it . i didnt leave the car running and have since then haven't even attempted to start it again . I really like my car for the most part it has driven really good for me and i want to keep it going for as long as i can .I am asking because i dont want to mess up the car by running it like this but i dont want to have to spend hundreds of dollars i dont have taking it to a shop . so if there is ways that i can pinpoint the problem and do whatever research to read up and fix it myself then i would prefer to do it that way . Any advice or suggestions would be greatly appreciated
Sounds like the evaporate gasoline recycling unit underneath driver side rear tire hub needs replaced. One reason why you get leak code and car shakes . Engine might just be running hot because of all this.
 
1 - 3 of 3 Posts
Top