Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Just three day ago I had to put a new battery in the car because it was a cool night so installed new battery now the car i dead as a door i get dash lights but i do not get door locks or windows to roll its been at the dealers for four days now and they don't know whats wrong with it too.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
If they can't figure it out, I'm not sure what to tell you. I could only guess blown fuse, or a wire got disconnected, perhaps a code got set somehow that needs to be cleared even. But I would expect those to be the first things they check, unless you got a faulty battery...
 

·
Premium Member
Joined
·
954 Posts
I am sorry to hear about your concerns MB1969. Feel free to reach out to me or Katie with more details including the last eight of your VIN and dealer name, and we would be happy to look into this for you. Thank you in advance.

Tricia, Chevrolet Customer Service (Assisting Katie).
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
ok we are going to install a new key module to see if that fixes all the problem, all the wiring and fuses tested great and if that does not work its time put in a new BCM board in to see if that fixes it lets hope so
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
update guys got new BCM in and new PCM and key module too took it to the dealer and had them reprogam then bcm and its all good and running but at the dealer someone hit the car rear bumper now they need to fix it. Its not bad at all but they need to fix it. Thank God She's running again....MB1969
 
1 - 6 of 6 Posts
Top