Impala Forums banner

1 - 9 of 9 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
How many other people are having problems with their 2006 Chevy Impala? What problems are you/have you experienced? I like the car, but there are things going on and I'm just wanting to see if it's a common problem or if it's just the characteristics of the vehicle. I'm getting so close to 36,000 miles and am trying to decide whether I should keep it or trade it in for a new model.
Occassionally the RPM's increase when tranny tries to shift from 1 st to 2nd. Even with seatbelt on, the car dings while driving..occassionally. Steering wheel flutters when I'm turning to the left or right, it's especially bad when I'm stopped and then accelerate while turning. Sometimes when I go from Reverse to Drive, the tranny takes longer to shift, if it shifts normally then it'll slam into gear once I'm already moving. Some times the radio won't turn off, sometimes it won't come on..kinda like it's locked. This is where I am: Are some of these things normal electronic problems or are they characteristics of new cars? If they are problems then I can take it to the dealership to get them fixed, if they can get the car to do the same thing for them...if they fix everthing the first time, then am I going to have the problems for the remainder of the time I own this car?
 

·
Super Moderator
Joined
·
7,057 Posts
I would get this car to the Chevy dealer now before the bumper to bumper warranty runs out.
These problems are not normal and must be addressed.
If they fix it properly you should not have any further trouble.
Also if you trade it in now they will deduct some of the value from the car because of the issues, so if wanting to trade up you do want them to fix it now.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #3
i have one and i love it i havent had any problems with mine that were major but i want a truck so i will most likely be giving it to someone like my bestie at work and getting myself a truck...good luck

dean
 

·
Registered
Joined
·
1 Posts
Does anybody know what the clamp on the positive battery cable is on 2006 chevy impala?
It looks like those electrical clamps that you put around wires to measure current. Are these supposed to be turned a certain direction or be a certain distance from the battery terminal? My battery light keeps coming on and the code said something like 'current reader in wrong position'. Any ideas?
 

·
Super Moderator
Joined
·
10,950 Posts
Take a pic of what you mean please
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #6
2006 ignition and electrical problems

TRADE THAT CAR!!! I have a 2006 Impala and it has severe electrical issues. I have replaced the shifter kit/solenoids twice. They have ignition switch problems which GM is denying for this year. I have been trapped inside my car twice with the ignition locked up. No hazards- NOTHING. The car is now sitting in my front yard after being towed here. It DID the same thing and locked up and shut the entire power down. No lights, no hazards, NOTHING. Currently looking to have to towed to GM Monday. The only recall they say for the 2006 is the power steering. This last lock up could have resulted in death for me and my children due to the lack of lights and trapped inside. I have been told it could also be the computer module which costs around 2000. GET RID OF THAT CAR WHILE YOU HAVE THE CHANCE.
 

·
Registered
Joined
·
1 Posts
Hi, I have a 2008 Chevy Impala with 80,200 mi and I have had REALLY wierd things happen recently while driving. The first time it happened all my guages went down, lights turned off (headlights and interior), and my stereo turned completely off as if the car was off. Along with the tire pressure, air bag, and I think the anti-theft light all came on follwed by the messages on my dashboard. I pulled over. Cut the car off and started it back up and none showed up for about 5 minutes then they all started again. About a week later it did it again but it also start dinging while driving (the ding noise when your car is off door is open but key is still in the ignition noise). Now about another week later present (5.1.2015) I am not getting any lights on my dash board but I get the dining noise only in my front driver speaker and my stereo turns on and off!! Ugh this is so annoying. I do not have the factory stereo and have an amp and subwoofer they were all installed at a professional shop over 1 year ago and have not had any problems with any until now but I am thinking about taking it all out and putting my factory stereo back in to see if it is related to those items...
 

·
Registered
Joined
·
1 Posts
I have a 2006 impala 3.9.. The car picked up a shimmy and a hop under exeleration. I found a egg shaped tire on the driverside front axle. Replaced tires ( 4 ) and tie rods and an alignment. Still had shimmy and hop. Was told driverside axle and bearing pack had play. Replaced both . Still has shimmy and hop. Rebalanced tires was told I had bent rim. Replaced rim. Still has hop, going to replace passenger side axle and bearing pack tomorrow. Any suggestions on what it might be if the next axle replace doesn't fix it ?? Spark plugs have been replaced also. Runs great other than the hop when exelerating .
THANKS in advance.
 
1 - 9 of 9 Posts
Top