Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an 05 Impala that if I push the gas too fast the car takes a minute and then jerks forward. Or when I get up between 20 & 30 it does this slip or feels kind of like a stutter. Does anyone have any idea what this might be? The transmission fluid is not low and still has great color. The boyfriend thinks it might need a transmission filter replacement... Any ideas would be much appreciated! TIA!!!

Shelly
 

·
Registered
Joined
·
2,975 Posts
I have an 05 Impala that if I push the gas too fast the car takes a minute and then jerks forward. Or when I get up between 20 & 30 it does this slip or feels kind of like a stutter. Does anyone have any idea what this might be? The transmission fluid is not low and still has great color. The boyfriend thinks it might need a transmission filter replacement... Any ideas would be much appreciated! TIA!!!

Shelly
When you say you "push the gas too fast the car takes a minute and then jerks forward", does the motor rev, then the car jerks forward? Or does the motor bog down, then rev back up, pulling the car forward? From what I've read, it's not clear if you have a transmission issue, or an engine issue. Is your boyfriend sure it's the transmission?

Doug

.
 

·
Read Only
Joined
·
13 Posts
Whatever you do don’t flush the system. Drain and refill a few times with new fluid each time, use the cheap stuff for the first 2 drain and fills. Use full synthetic for the last fill. Replace filter before final fluid replacement. This worked for me, no promises though.
 
1 - 5 of 5 Posts
Top