Impala Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i have a 2004 3.8l vin k and i got a motor from salvage yard that was fairly new but came out of a Lumina. ive had to swap a few things,put new crank sensor in,new starter ,radiator wasnt the same as my stock 3.8l that blew up due to my family running it hot and its been sitting since 2016. but long story short the motor bought still even had good oil in it so i never even changed it,but we finally got it started over the weekend and its making a loud rattling noise,its idling high then coming down,and its not smoking like its blown up or anything. the guy refuses to stand behind his motor sale so instead of arguing with him i feel like this can be fixed and i did only pay $400 for a fairly new 3800 series V6 (even though its got a few kinks ) i think its fixable, but it will run all day long but idling problems and as soon as it starts it says low oil pressure,any ideas on what i should do next(besides get the old gas out of it!!
 

·
Super Moderator
Joined
·
228 Posts
Doesn't seem like it would be an ECU issue here, the knock sensor might be cutting back the timing and this is causing the idle speed droop but the knocking would defiantly be mechanical and cause for alarm.
You said it was out of a Lumina (W-body) but what series is the engine itself? I seem to remember the Lumina sedan was a 60 degree V6 be it 3.1L and don't recall a 3800 anything under the hood, van was a 3800 wideblock (old series) so this is what has my curiosity going.
Regardless of the series the knocking is cause for alarm and if the seller isn't willing to stand behind it then you will have to investigate this on your own.

Perplexing...
 
1 - 3 of 3 Posts
Top