Impala Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2004 Impala, my speedometer is doing wacky things.
It dropped back to 200 kph when stopped, then dropped back to 160 kph when stopped and keeps dropping back every couple of days.
What is the fix? If the cluster has to be changed, are there remanufactured ones, can they be repaired, or should I just get OEM?
 

·
Registered
Joined
·
588 Posts
It could be a few things... To start out and something that don't cost you anything but some time.. Check all your Wiring and grounds for your car. Make sure the battery is well clean. I would take some Baking soda and water mix and clean off the underhood connections well..

Then make sure all your grounds from your BCM and the cluster are connected well with no corrosion or rust on the connections.

Then the other thing is that it could be that the Stepper motors or going bad... You can get new Stepper motors from RockAuto or even the bay. Clusters as well at Rockauto but carry a 300 core, There are companies that sale them on the Bay and say they will program with your miles for your car... Then there are others that just sale them miles unknown. Or depending where you are maybe someone could pull one from a yard for you. Like for my area they are 40 from a pull yard then the cost to ship it out to you.

With your year of car, You can use the cluster from Impala, or Monte Carlo, If you were looking over the MC one, you could maybe get a Limited one that was signed by a Racer. However if you have a base model Impala you may want to stick with your own type of cluster or maybe upgrade to the LS one because on the Base some of the extra gauges on the Sport Cluster/Monte Carlo cluster won't work...

James
 
1 - 2 of 2 Posts
Top