Impala Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
hey my wife has a 2004 impala and for the last 4-5 months sometimes the car will stall and sometimes it'll start right back up and other it won't even crank at all. At first i thought it could be the passlock sensor so I changed it out a few days ago, and it drove fine till today where it stalled at a light. It did start right back up. There were other times it would stall while driving and wouldn't even crank at all so i'm at a loss here. Any ideas??? bcm maybe? I kind of doubt bcm as when it stalls I dont see a security light, but I have seen it when it wouldn't crank.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Probably ignition switch, BCM won't keep the car from starting or running.
 

·
Mr. Handy
Joined
·
6,289 Posts
Did you just change the passlock sensor or the lock cylinder as well? Whenever you have a starting issue based on passlock the complete cylinder and ign switch should be replaced. All of these components can cause starting/stalling issues.


Do you have any dash lights on? If so, have codes scanned at a local autoparts store.

These ignition switches/cylinders are SUCH a common problem that I am getting sick of hearing about them

Edit: GM fails to issue a recall on this known problem. I would say at least half of all 00-05 impala's with over 100k miles have this problem which, most of the time ends up getting replaced by a GM dealer and costing over $300. These ign switches and cylinders tend to crap out at around 80-120k miles. Depending on use and cleanliness of course.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
I haven't changed the lock cylinder just the passlock sensor from my impala that I know worked fine while it was in it. I guess that'll be my next stop the lock cylinder. I seriously doubt its the battery. No codes or any lights are on the dash. The last time it wouldn't crank I tried the 10 minute relearn and it still didn't crank, just happened to try again later on in the day and fired right up.
 

·
Mr. Handy
Joined
·
6,289 Posts
I haven't changed the lock cylinder just the passlock sensor from my impala that I know worked fine while it was in it. I guess that'll be my next stop the lock cylinder. I seriously doubt its the battery. No codes or any lights are on the dash. The last time it wouldn't crank I tried the 10 minute relearn and it still didn't crank, just happened to try again later on in the day and fired right up.
I would replace the ignition switch and the cylinder :eek:k3:
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Happy to report I installed a rebuilt ignition switch along with passlock sensor over 2 weeks ago and so far so good no stalling or refusing to crank/turn over. Normally it would take a day or 2 before it would happen. Thanks for all the advice.
 

·
Back in Black
Joined
·
4,127 Posts
Thanks for the update
 
1 - 8 of 8 Posts
Top