Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Our son has a 2004 Impala LS for school and it's been good, except we recently noticed that the oil was low... the warning lite came on - so we added 1qt and now (800mi later) it's down again.

There are no oil spots on the floor, and no blue smoke :)

We'll have to see how long it goes before the dipstick says we are down again.
I've been using the high mileage synth blend to add.... guess the only place is leaking into the cylinders :(
 

·
Super Moderator
Joined
·
7,057 Posts
How many miles are on the engine? A trick to try is rev the engine up to 2 to 3 K rpms and hold for about 1 minute. Then see if you find spot(s) under the car. Might lift the car and see if any engine componets have a coating of oil on them. If still nothing then have the cylinders compression tested. Hope it is nothing major.
 
M

·
Guest
Joined
·
0 Posts
you can pull the plugs and look at them too. if the cylinders are burning oil, the plugs will show it.
 

·
Registered
Joined
·
5 Posts
I have an '06. Same thing happens to me. It seems to be spontaneous too. One day the oil will be fine and not more than a week later I'll be a quart low. No drips, spots, nothing. Thank god for the idiot light / message.

I hate this because I DO check my oil on a regular basis as well as my other fluids, belts, hoses, and tire pressure.
 

·
Registered
Joined
·
557 Posts
the newer motors like in the 06, have oil jets, so if you hammer on it, you'll lose oil. As far as the 04 LS, take off your engine cover and see if you have any oil sitting on the lower intake.
 
1 - 5 of 5 Posts
Top