Impala Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2004 impala that has given me the code that the engine is running cold. coolant is fine but once a week I drive a stretch of hiway about 15 miles long and to be fair it has been cold in the high 20s but everytime after that, as soon as I get off the freeway the light comes on (check engine) but after driving it for a day it goes off? What gives? any suggestions on where to look.:bang:
 

·
Back in Black
Joined
·
4,127 Posts
what is the code # ?
 

·
Banned
Joined
·
667 Posts
I have a 2004 impala that has given me the code that the engine is running cold. coolant is fine but once a week I drive a stretch of hiway about 15 miles long and to be fair it has been cold in the high 20s but everytime after that, as soon as I get off the freeway the light comes on (check engine) but after driving it for a day it goes off? What gives? any suggestions on where to look.:bang:
goes off after 3 cold start cycles.

but turns on after it gets triggered again.

Code(s) will be stored in the computer.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
P0128, try a new thermostat
 

·
Registered
Joined
·
116 Posts
My impala has run super cold since winter my advice is grab some cardboard and duct tape completely block the radiator then go up underneath there's two air inlets next to the dogs tape them off then pull your grill and completely tape off the back of that too the only place my car is pulling any air is the gap between the bottom of the bumper and the radiator it's taken me over a month to finally figure this all out but my car is now running where it did in the summer. The heat is better the car runs better and it doesn't take forever and a day to warm up I'm not sure where you are but this is the first car I've had to do this for but I live in Michigan I'm glad I finally got my gas mileage back I'd check your thermostat first if that's good take a half hour and do as I said above good luck
 
1 - 9 of 9 Posts
Top