Impala Forums banner

1 - 4 of 4 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
It has 80,000 Miles on it. I have noticed when taking off from a start if I go hard it can shift hard at times. It is not a huge concern and in overdrive it seems fine. In the maintenance schedule it says to get it serviced change the fluid and filter at 100,000 miles, unless you drive in extreme conditions which I don't. It has almost always been like this, my step Father works for GM and drive a 2008 impala and says that it is a common problem with the computer when starting the engine from a stop. I really do not feel like having to rebuild the tranny, the fluid looks brownish red and no visible specles or anything or any signs of burning or things like that. I know that Impalas can have tranmission troubles at 80k to 110k I am just wondering if I should be concerened. My step dad who is a huge car buff and like I said works for GM has no real concern when I told him about this.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #2
the problem is probabilky within the computer of the car, these days you cant even change your own tire on a car.
 

·
Registered
Joined
·
14 Posts
Impalas/Monte Carlos are known to have transmission shifting problems in that mileage range. From what I've read in consumer reports, most of the time the solenoid on the tranny is replaced or the entire tranny itself is replaced. But then again your step dad could be right. I'd recommend performing a tranny service with filter kit and take it from there. Also have them look at your lower intake :smile:
 
1 - 4 of 4 Posts
Top