Impala Forums banner

21 - 25 of 25 Posts

·
Registered
Joined
·
2,738 Posts
1. DIC dead.

2. Cruse control stopped working.

3. HVAC has a mind of its own - recirc, A/C buttons do nothing but it'll randomly switch from recirc to fresh and run the AC so I pulled the fuse that allows the A/C pump to run because it would engage the pump when the HVAC fan was off.
I'm thinking bad ground somewhere under the dash. Do you have any schematics for the car? They might be helpful, but even without them, you can inspect the wiring harnesses under the dash.

Start at one of the failing units, such as the HVAC controls, and trace the harness back from it looking for a connection to ground. I'm guessing a ground wire broke loose from its eye terminal, and that is causing the DIC and cruise failures, and wonky HVAC.

HTH.

Doug

.
 

·
Registered
Joined
·
111 Posts
I'm thinking bad ground somewhere under the dash. Do you have any schematics for the car? They might be helpful, but even without them, you can inspect the wiring harnesses under the dash.

Start at one of the failing units, such as the HVAC controls, and trace the harness back from it looking for a connection to ground. I'm guessing a ground wire broke loose from its eye terminal, and that is causing the DIC and cruise failures, and wonky HVAC.

HTH.

Doug

.
Thanks Doug,

I don't have a schematic, I took a quick look around up under the dash, but cant spot any grounding points, this looks like a very time consuming exercise with out information on where all the grounding points are.
 

·
Registered
Joined
·
2,738 Posts
Thanks Doug,

I don't have a schematic, I took a quick look around up under the dash, but cant spot any grounding points, this looks like a very time consuming exercise with out information on where all the grounding points are.
I found some ground drawings for the 3 items: DIC, HVAC and Cruise (CCM). Post or PM me your email and I'll gladly send them to you.

Checking them, it's not obvious where the problem might be. Ground G201 is shared between the BCM and the HVAC. G203 is shared between the BCM and DIC. Both of these are located above the driver's knees as best I can tell from the attached pic.

I would check there first.

Doug

.
 

Attachments

·
Registered
Joined
·
111 Posts
I found some ground drawings for the 3 items: DIC, HVAC and Cruise (CCM). Post or PM me your email and I'll gladly send them to you.

Checking them, it's not obvious where the problem might be. Ground G201 is shared between the BCM and the HVAC. G203 is shared between the BCM and DIC. Both of these are located above the driver's knees as best I can tell from the attached pic.

I would check there first.

Doug

.
Awesome, thank you Doug! PM sent with my email.
 

·
Registered
Joined
·
111 Posts
Today I took things apart, cleaned G201 and G203, added star washers and greased everything with Jet-Lube SS-30 pure copper anti-seize (I happen to have).

No change, as soon as the key was turned around to ON the security/battery/service soon messages came back, and the radio would cycle between locked and on every few seconds.

Since things were apart already I figured I'd take the dash apart, get the radio out and give G202 (https://www.impalaforums.com/chevy-impala-7th-gen-discussion/567506-electrical-nightmare-bcm-plugs.html#post1564578) a clean, star washer and a dab of copper anti-seize.

Put everything back together, for now at least the security/battery/service soon messages didn't come back and the radio was behaving it self. I was able to get into the settings and reset the oil life warning - something I've not been able to do since the security/battery/service soon messages appeared a few months ago. So some progress, hopefully permanent.

However the DIC is still dead, HVAC still in lala-land. I think when I get the car in for the two recall items (spark plug wire retainers and unintended key rotation), I'll ask them to do a diagnostic on the BCM to see if thats part of the problem or rule it out.
 
21 - 25 of 25 Posts
Top