Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I have a 2001 Impala with a 3.4 V6 stock engine. Friday my security indicator light came on this has happened a few times the manual said it's a warning that the pass lock system is not functioning. This morning I went out at my normal time 0500 EST to start it to go to work and everything headlights radiao internal lights but not the ignition came on when I tried to start it. I tried several times I moved the selector (Auto Trans) to neutral and tried with the same result. I'm going to try disconnecting the battery when I return home this afternoon and see if it will reset. Any Ideas would be greatly appreciated.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
My Impala

I failed to mention that the vehicle sat all weekend and since yesterday was such a nice day I washed it. I'm wondering if something is wet that shouldn't be.
 

·
Registered
Joined
·
416 Posts
I dont think that washing the car would affect the pass lock sensor. The pass lock sensor is part of the case that the cylinder slides into. The part number for the ignition cylinder is 15822350. The parts will run you ruffly about 220 for the cylinder and pass lock sensor.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Thanks

Hey you can't blame me for wishful thinking. I guess I can install the switch and sensor but will have to have a dealer reset the system. Will it operate (start) without them resetting it?
 

·
Registered
Joined
·
20 Posts
Had the security issue on my 2001. Had a local radio shop install a resisitor last fall(2008). no problems since....

Well no security function as well......but the car start everytime.

cost was $60.00
I had t ocall about 4 radio shops. Most were familiar with it but one claimed they did it on plenty of impala's
 
1 - 6 of 6 Posts
Top