Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I'm trying to sell my 1996 SS but the dash cluster is messed up. Its the analog cluster with the digital odometer.

1) Tach works
2) Speedo works
3) All other analog gauges do not work.
- gas gauge
- oil gauge
- water / temp etc.
4) Odometer light flickers sometimes on sometimes off.

I bought another dash cluster online but didn't realize that the cluster itself stores the cars mileage / VIN information-- But when i had it installed, THAT cluster didn't work either. Exact same problems.

Could this actually be a dash cluster problem or is this an electrical problem?

NOW- the bizarre thing- I took it to 2 Chevy dealerships. BOTH of them told me they have no idea where to even begin diagnosing the issue because the car was so "old".

Everyyything else on the car is awesome. But i cant sell it like this. Please help!

Thanks!
 

·
Banned
Joined
·
97 Posts
I'm trying to sell my 1996 SS but the dash cluster is messed up. Its the analog cluster with the digital odometer.

1) Tach works
2) Speedo works
3) All other analog gauges do not work.
- gas gauge
- oil gauge
- water / temp etc.
4) Odometer light flickers sometimes on sometimes off.

I bought another dash cluster online but didn't realize that the cluster itself stores the cars mileage / VIN information-- But when i had it installed, THAT cluster didn't work either. Exact same problems.

Could this actually be a dash cluster problem or is this an electrical problem?

NOW- the bizarre thing- I took it to 2 Chevy dealerships. BOTH of them told me they have no idea where to even begin diagnosing the issue because the car was so "old".

Everyyything else on the car is awesome. But i cant sell it like this. Please help!

Thanks!
Looks like they are trying to make a new car sale. When I'm thinking about a old car I'm thinking about something from the 60's and before. and not something from the 90's :dunno:
 

·
Super Moderator
Joined
·
3,946 Posts
Dealers are going to rarely see a 10yo car much less older yet.

The fading odometer is common.
with the other symptoms though I would be looking for a ground issue under the dash.

The oil pressure gauge is really just a dummy light it is not properly functional without modifying some stuff.
The water temp sender for the dash is in the passenger side head in front of the last exhaust port kind of, the one in the waterpump is for the pcm.
Gas gauge is fairly commonly inaccurate at low levels.

Far as I know the cluster holds no VIN info just the mileage.

There are guys who can resolve the fading issue but there is more happening you need to find first.
 
1 - 3 of 3 Posts
Top