Impala Forums banner

1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
I bought a 1991 caprice from my uncle, he said all it needed was a fuel pump and a steering column...I replaced both but was trying to find out if the pump is bad because the car will crank but will not start.
I got the pump on and my mechanic said the wiring was crossed up and when he fixed it he then said that I need a new ECU because the pump works ( I heard it for myself) but gas wont enter the TBI to let the engine turn over and run, is this true or could it be bad fuel injectors ?
 

·
Registered
Joined
·
94 Posts
Well...

Did you check the fuses? Did you make sure that the fuel pump is properly connected? Check those first. If they are ok, I'd suspect a clogged fuel filter. They are cheap, and even if it ran great, you should change it anyway, so go ahead. Visually inspect the fuel lines, tank to throttle body, making sure that none are pinched, or otherwise faulty. Disconnect the control wire to make the coil fire (the wire from the ignition control module on the distributor, that goes to the coil) since we will be handling raw fuel, we don't want a random spark. Safety first. Get a short piece of hose the right length, and disconnect the fuel in line on the throttle body, run the hose into a basin (gasoline resistant, an old glass mayonaise, or peanut butter jar works great) and have an assistant turn over the car. That'll let you know if the fuel is going to the tb. After that, repost and we'll trouble shoot some more.
 

·
Registered
Joined
·
1 Posts
im havin da same problem. i bought a new fuel pump nd filter nd nuthin still isint comin out of da fuel injectors. da car sat for 2yrs so i kno problems r gonna occur. plz help
 
1 - 3 of 3 Posts
Top