Impala Forums banner

1 - 3 of 3 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
MY caprice first started to smell really rich on fuel then it was dying out which ended up being the coolant sensor was short circuited
but the rich fuel smell stayed then the stalling came I put the car in drive it stalls when I try to take off l hate it so I did a full tune up and still nothing changed cap rotor plugs wires fuel filter and still no progress took it into a chevy dealer they said the timing was off so 250 bucks later it still does it help me please!!!! my thoughts are fuel pump cam or tbi pod but I'm not for sure
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Check for vacuum leaks. Finding a shop with a smoke machine is the best way to find leaks, or you can use a can of carb spray. Spray around engine, hoses, etc. If you here the RPMs go up you've found your leak. I would also try the Oxygen sensor.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Stalling could be due to transmission overdrive stuck in lock down (CCV) symptoms would be stalling after the car is warm and has exceeded 45mph. It will start to chug as come to a stop and stall or will start and idle fine but stalls immediately after being put in drive. If this the case then let the car cool and get the CCV to unstick and unplug the connector going into the transmission so it never locks down again.

Check TBI spray pattern (no drips) check EGR for sticking, check for vacuum leaks, check IAC for functionality and passageway is clear, have Mapp or MASS checked.....
 
1 - 3 of 3 Posts
Top