Impala Forums banner

1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
car is very nice never stopped on me before....but yesterday for the first time it suddenly stopped .....it started vibrating and then stop running.....but i can start it back up again ...but now vibrating and stopping about every 5 miles .....please help!......thanks
 
G

·
Discussion Starter · #2 ·
I take that it died and not running at this time,If this is the case ,then it could be many different thing ,It could be the fuel pump has went out or your ignition module has went bad ,.If you could give use some more info .Like is it running now,is it getting fire or gas what is it do.
 
G

·
Discussion Starter · #3 ·
check your alternator and your battery. A simple test for this is to start your car on a straight road with no traffic. Turn on your headlights and start driving after a few seconds turn on your stereo. Watch your dashlights while turning on your stereo. If they dim excessively you might need a new alternator. Otherwise clean your battery terminals and get your battery checked at a local autozone or advance auto.

Also, if your car does this again after checking out the battery and alternator. Put it into drive and take it to a good mechanic for a diagnostic. If you can find an old crusty dude that looks like he might have designed the car then even better. Most of the mechanics around today don't know alot about older vehicles.

Good Luck
 

·
Registered
Joined
·
2,102 Posts
Have you bought some no-name gas lately?, could be some water in there.
 
1 - 5 of 5 Posts
Top