Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i just finished fully restoring this 63 impala ss with a 327 and a powerglide 2 sp. runs great but after i drive for around for a while like couple hours. and then i stop at a light car sometimes wants to die. also if i park the car it wants to die when i put into gear so i have to brake/ gas at the same time to keep it from dieing. I've had timing checked and rechecked a few times, leak tested everything, running a edelbrock 600cfm carb, all engine is stock but rebuilt. stock tranny rebuit. any advice on what to look at next for possible fix.
 

·
Registered
Joined
·
480 Posts
i just finished fully restoring this 63 impala ss with a 327 and a powerglide 2 sp. runs great but after i drive for around for a while like couple hours. and then i stop at a light car sometimes wants to die. also if i park the car it wants to die when i put into gear so i have to brake/ gas at the same time to keep it from dieing. I've had timing checked and rechecked a few times, leak tested everything, running a edelbrock 600cfm carb, all engine is stock but rebuilt. stock tranny rebuit. any advice on what to look at next for possible fix.
Fuel pump? I'm no expert for sure. Just an idea. Also this is posted in the wrong forum, it will get more attention if you post it in Automotive Discussion or Mechanical and Electrical Problems. If a mod sees this they can move it to a more helpful and appropriate place.
 
1 - 3 of 3 Posts
Top