Impala Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
Engine light came on, took it to autozone for diagnostics and P0455 came up

"EVAP Large leak detected"
Probable cause
-Vacuum leak at engine
-purge or vent solenoid defective
-defective, loose or missing fuel cap
-EVAP canister broke, hose cracked or not connected.

Message came up in the car yesterday to "tighten gas cap" I forgot to do it until today after the engine light came on, but the light still has yet to go off. Last time gas was put in was on Sunday so that leaves three days with a loose gas cap. I was thinking to just unplug the battery to reset the engine light and if it comes backs on then it's something else. If the problem is one of the things listed would it need to be taken care of immediately or could I still drive the car and hold off until tomorrow. Reason being I have class in the morning and this is my only means of transportation.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Its easy yes, its mounted by the filler neck, you can get it from underneath. However, EVAP codes typically take a week or so to self clear, so that is more likely the problem. It won't effect anything except emissions testing as it is.
 

·
Registered
Joined
·
761 Posts
My engine light just came on, i never got the "tighten gas cap" message, do you think mine is the EVAP sensor thing?
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Is it a P0455 code?
 

·
Mr. Handy
Joined
·
6,289 Posts
Unhooking both battery cables and turning the ignition to "on" for 10-15min WILL reset all codes. That's the easy way that doesn't require going down to AA or Autozone.
 

·
Registered
Joined
·
761 Posts
Is it a P0455 code?
i havent gotten a chance to go down to AutoZone yet to get them to check. The car runs fine, just my remote start wont work.
I just read a thread where someone else said their remote start wasnt working along with getting a engine light and they changed their evap solenoid and that worked for them, so i just placed my order for a evap solenoid from rockauto.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Well, I hope that works for you, but the concept isn't so simple. Any code setting the check engine light will disable the remote start, you should find out what the code is before trying to fix it...
 

·
Registered
Joined
·
761 Posts
Ok, I get what you're saying, I'll head over to Auto Zone tomorrow since I'm off and let them do their magic...if it isn't the evap thingy I'm glad I only wasted 23 bucks and not more......
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Touche
 
1 - 12 of 12 Posts
Top