Impala Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys,
I have a 2006 Impala and the left rear blinker doesn't blink. The bulbs and fuses are ok. I tried turning the hazards light on and off, but that didn't do anything.
I read elsewhere on the forums that the hazard switch would need to be replaced. With the 2006, the hazard switch is built into the turn signal switch so I'm assuming I would need to replace the entire switch. How much of a job is this?
Thanks for all replies.
 

·
Premium Member
Joined
·
954 Posts
Welcome, JJMilwaukee! As a Customer Service representative, I unfortunately am unable to provide DIY information for you; however, I do hope to see fellow forum members chiming in soon with advice! I'm happy to help in any way I can, so please send me a private message anytime that you would like further assistance. I'm always happy to check for recalls, locate and/or contact your dealership on your behalf, etc.

Best,

Katie
Chevrolet Customer Service
 

·
Registered
Joined
·
226 Posts
sounds more like a wiring issue around the left rear tail light. is it goin into hyperflash?

wish i could help more but i have an 8th gen. but youd b surprised how easy it can be to remove parts of your dash and replace components. and im sure theres a sh!t ton of info on here on how to do it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Haven't got to it yet, but there's was some other electrical issue now related to the blinkers. The clicking sound of the blinker sporadically went off and on today. Any thoughts on if that is related to the turn signal switch as well?
 

·
Registered
Joined
·
226 Posts
did u try turning the bulb 180 degrees? i doubt thats it but u never know. to rule more possibilities. take the bulb from the other tail light and switch them.
 
1 - 7 of 7 Posts
Top