Impala Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hello.

I am new to impalaforums.com and forums in general and also I know nothing about cars so please bear with me.

Last night at 2am and it was about 10 degrees out (I say the temp because it might matter?) I started my car, let it warm up to normal running standard and backed up. My car moved backwards but the wheel would not turn at all. I pull forward into my parking spot and noticed that the wheel is extremely hard to turn left or right... almost impossible.

I check under the hood and noticed that my car was leaking something onto the group but it was dark and I couldn't quite see what it was.

Checked this morning and I found that my power steering fluid was completely empty. I had a half bottle in my trunk and put it in my car, then turned my car on. All of a sudden I noticed that the fluid is leaking onto the ground. Not really leak, more like a slow/medium pour and the wheel still wouldn't not move. I'm not able to see exactly where it is coming from without getting directly under the car. From an angle view, it seems to be leaking from the mid front of the passenger side about a foot behind the right pass tire.

Can someone possible tell me what might be the issue here? I don't have a mechanic that I can go to besides a chain location shop and I just wanted an idea of what it could be before I left them rape my wallet.

Thank you in advance.
 

·
Registered
Joined
·
3,227 Posts
Power steering line to the rack or leaking past the end of te rack by your inner tierod. Make sure it isn't coming from up higher though and running down and endin up there. My bet is a power steering line though.
 
1 - 2 of 2 Posts
Top